Issues with Jails after updating to TrueNAS 13

Took the plunge and updated to R.13 last night. Two of the jails have issues now.

If i run wget in one jail, I get the error message: /lib/ version FBSD_1.7 required by /usr/local/bin/wget not found

In another jail, the newly upgraded Thunderbird (upgraded automatically during the jail upgrade) fail with the same complaint about libc.
But libc is definitely there:

$ file /lib/ ELF 64-bit LSB shared object, x86-64,
version 1 (FreeBSD), dynamically linked, for FreeBSD 13.0 (1300139),

I tried to remove and reinstall both wget and Thunderbird, but that didn’t solve the issue.
I found Thunderbird 91.1.3 in pkg cache, removed Thunderbird and installed the cached version. Now I can start Thunderbird again.

I also tried to force reinstall all libraries. That didn’t resolve the issue either.
Anyone know how to fix this issue?

There are a few plugins that no longer install or work in 13. I don’t really have any suggestions as I think jails are no longer being well supported for TrueNAS Core.

1 Like

Thanks Tom,

A bit concerning if jails are falling out out of favor.
I use jails, not for the standard plug-ins, but to create isolated freeBSD environments.

I did manage to get them running again.
During the upgrade from 12 to 13, the jails where updated to 13.0.
While TrueNAS thought they jails had been updated, in actuality, they were still running R-12, even though they were marked by TrueNAS as running 13.0.
E.g. /etc/os-release were listing the release as 12.2.

I solved the issue by fetching 13.1. Then update the jails again.
This time the update took effect, and the jails were correctly updated to 13.1, and are running fine now.