Issue with SR-IOV on XCP-NG

So I have a pfsense VM that I want to pass through three of the 4 ports of my Intel i350 Network Card integrated in my HP dl360e g8 server running XCP-NG 8, and what I found online is the best way to do that is through SR-IOV. However, when I follow this guide: However, I get this error on the console when booting:

igb 0000:02:00.[0 through 3 for all my NICs): can’t enable 7 VFs (bus 03 out of range of [bus 02])

The networking tab in the XCP-NG Center Application also says “Host need reboot” in the SR-IOV Column.
I also noticed that there was specific instructions at the bottom of the instructions for my NIC, but when I tried those it just said 4 VFs instead of 7VFs in the error like I set it to in /etc/modprobe.d/igb.conf file.

I have verified that all virtualization features, including SR-IOV are enabled in my BIOS. I have also tried doing a PCI pass through using the instructions here: with no success, vm doesn’t start when I attach the device to it. Any Ideas?

I have not done any testing with the SR-IOV network interfaces, their forums might be a better place to ask.