Issue acme certificate in pfsense

I am following along with the tutorial for configuring HAProxy and certificates for internal domains. I am having trouble validating an acme certificate because my whole network by default connects to the internet through a VPN. When I go to validate the certificate it fails because the ip address returned is the VPN ip address and not my local internet provider ip address. I have tried forcing several different addresses out through the WAN but nothing has worked. I have tried the url with a blank and the domain and I have also tried sending and Nothing has worked. I would be grateful for any advice.

use dns method if your first option is not working.