Is my MB/DIMM ruined? No boot when DIMM bank populated TS440

I’m doing a RAM upgrade on my TS440 and I’m running into some issues.

I have 4x8GB sticks and they are all known to work and be compatible with this motherboard (I tested them all one by one and by sticking them in my TS140 which is basically the same machine in a different form factor case (32GB detected success)).

For reference:

8GB 8GB 8GB 8GB Memory error beeps - no boot
8GB X 8GB 8GB 16GB detected
X 8GB 8GB 8GB Memory error beeps - no boot
X X 8GB 8GB 16GB detected
8GB X 8GB X 8GB detected
8GB 8GB X X Memory error beeps - no boot
8GB X X X Memory error beeps - no boot
X 8GB X X Memory error beeps - no boot

It seems like there is something wrong with DIMM1 and/or DIMM2. I don’t see any obvious physical damage to the motherboard.

Update: It seems booting with this ram is unreliable even on my TS140. I run into kernel panic errors when trying to boot TrueNAS when I have all 32GB installed. And then when I restart it won’t POST with no indication of failure. Just black screen and fans running. I have to remove all but one stick in DIMM0 to even get to the BIOS menu.

It looks like I can only have two DIMM slots filled at a time, so I am currently running Memtest86 on two sticks and then tomorrow morning I’ll test the other two. I suspect I may have bought some DOA RAM. The ebay listing was suspiciously cheap.

Have you done any changes to your bios? reset the bios to factory and try again. The memory sticks are ok (you tested them on ts140), so this machine’s bios is having issues. Just a thought.

Thanks that’s a good troubleshooting stop I hadn’t tried.
I just reset the CMOS battery and tried again, same thing.

It sure looks like DIMM 1 and 2 have an issue, but that issue may not be what you think. Pull the processor and look for dirty pads and bent pins. I had some Intel workstations that were constantly having RAM problems, and every single time is was a problem with a pin on the processor, and often it was bent pins. You’ll need a good magnifying device to see the pins and if the are bent. I spent months chasing this issue on 27 different computers for more than a year until they were finally old enough to replace. if only I could get all that time back again.

Just a guess, but if you have rotated the RAM into the “working” slots to check each and every module, then I’d look at the processor. I’d also check and update the BIOS too.

{edit} may have missed the update part of your post. But still good stuff to know when dealing with these issues.

According to Lenovo, there is a bios update dated 26 may 2020.
Memory sticks were OK in the TS140.

We don’t know if the TS440 has the same bios as the TS140 he tested on.

Thank you for the advice, I too have had bent pin issues. Very annoying as it’s the last place you look.

Both of these machines are running the same May 2020 BIOS.

Alright, so I ran one pass over each stick of memory two at a time. Both tests passed with zero errors, however on a whim I tried to test all four again at the same time and I guess it was a fluke that I was able to boot, however this test revealed tons of errors.

Memtest86 ran for a few minutes, then crashed and restarted. It POSTed and tried to boot TrueNAS, but I got that same kernel panic (below).

  • Is this memory actually bad?
  • Why would running two at a time be okay but all four at the same time produces errors?
  • Should I just return it and get my money back?

This is the ebay seller I bought from. It seems well reviewed with good feedback, but could these reviews be fake?

I was suspicious that the sticks only had five memory banks on them (as pictured below) whereas most other 8GB ECC sticks have nine or so on each side. I decided to just go for it since it was a good price and the ebay seller’s feedback was good.

I’m leaning towards something being wrong with this RAM since it won’t work in either my TS440 or my TS140. Though it could be that a bug in the BIOS exists on both of these systems since they’re running the same BIOS. I don’t have any other ECC capable motherboards to test with though unfortunately.

It might be an issue with the timings hence reset the bios to factory and/or upgrade bios.

The memory is 2Rx8, meaning there are chips on both sides of the memory stick. The pic shows five chips on this side (with sticker), how many chips do you have on the other side?