IPsec VPN doesn't work 2 ways

I have at this moment a netgate 2100 in our HQ and a Pfsens Community installation in our datacenter. I have setup a IPsec VPN, that is working well. From our HQ i can ping to the datacenter and reach the servers. But the otherway doesn’t work. I cant ping the Pfsense installation from the datacenter, only in a specific way (when I choice LAN).

What i’m missing?

When I put it on Automatticly it fails.

Here some more images

Additional information
Datacenter direct on WAN internet
Lan PFsense

HQ behind a router in DMZ mode
Router > Pfsense
Lan PF Sense HQ

My guess is that you are missing the routes in the IPSec setup to get back to the other side. Also have you considered using Wireguard?

Well I tried OpenVPN and IPSec . All the same problem.

I have created a OpenVPN Server (Community Edition) and a OpenVPN Client on a Netgat 2100. I have configurated everything according to this video (How To Setup A Peer to Peer / Site to Site VPN Using OpenVPN On pfSense - YouTube). The connection is up-and-running.

I only can ping from the Client to the server, but not from the server to the client (ping from Pfsense GUI). What am I missing?

I tried allso IPsec VPN, there the same problemen.

Is your client device allowing ICMP / Ping?