IOT vlan network

Just created a vlan for IOT devices using a couple of videos by Tom. Hardware- pfSense running on a Mitac D2500 mini-itx, unifi AC-LR AP, and a rather old managed level 2 Dell switch 2708. Thanks Tom for all the information provided in the two videos. The video “How to Have One UniFi AP-AC-LR & Two WiFi Networks with pfsense, VLANS, & No Managed Switch” and " Access Points and Creating WiFi VLANs Explained Using UniFi Wireless".

All went really well until I tried to get thru the Dell Switch. The unifi switch seems much more straight forward. It has a web based interface which with the default settings displays vlan1 and all ports untagged. These are under vlan membership. Then there’s a section for pvid under vlan port settings.

I only have two nics on the pc. So, one for wan and the other lan. Hence the deviation from Tom’s video. All our pc’s are connected via Ethernet and mobile devices via wifi. So I created a “crapwifi” network. The secure network is and the newly created network is with a vlan tag of 10. There are no Ethernet IOT devices. We have only two. One Ring Doorbell and an Alexa Show.

I tried tagging the port to pfsense and the AP. Then using the pvid. Not exactly sure how this works in this particular case. Tom mentioned on the other video that since the tagging was between pfSense and unifi AP that the switch need not be involved. So I don’t understand why the switch didn’t work or what the proper settings are to get the tags thru the switch. So I reset the switch and took it out of managed mode and the tags worked right away. I only bought the switch because of its port mirroring when learning how to use Wire Shark.

I’ll migrate the two IOT devices tomorrow over to the newly created network.

If anyone knows how to properly setup the Dell Power Connect under managed mode let me know.

Thanks again Tom for the videos. It saved a lot of time researching. Oh, I had a little trouble figuring out how the new controller handles vlans on AP’s since they moved it. But the unifi forum took care of that issue.