Inter-clan routing not working after changing default gateway

This has been bugging me for a while now after I configured my load balancing set up with a FTTN NBN and 4G internet on my PFSense box. After I create the “Gateway groups” for the two WAN interfaces and configure the weight, I changed the default gateway on my LAN’s so I can take advantage of the load balancing feature. (Second and Third Screenshot)

But after changing that option, I will get load balancing. But I will lose inter-vlan routing instead. Is there some NAT or other related setting that I have to tweak in order to get inter-vlan routing to work again?

I have tried creating a rule that will let me talk to the other vlan but that didn’t work either. (The last two screenshots)

I would change your firewall rules - have a look at Basic Setup and Configuring pfsense Firewall Rules For Home - YouTube

  1. Allow access between your vlans and itself that require access

  2. Block access to between your vlans. Create a alisas RFC1918 and add RFC networks to this group. As you have it setup - all networks can access each other.

You add BalanceME as the gateway on the rules, please delete this on any rules

Set the default gateway to BalanceME , so you do not have to add the gateway to any rules - System - Routing Gateways , change ‘Default gateway IP4’. Internet traffic will use this setting

Example of pfsense (our setup) -

Main Lan

Guess Network

Change the firewall rules, to sort your requirements i.e. on the ServerSNSHIT network you may want to restrict access to the Management network from certain devices / IP’s.

I hope the above makes sense

Thanks for the reply. I was planning on adding more rules later on once I manage to sort out the Load balancing issue.

I just had a look at the “Default Gateway IPV4” but it seems like it will only work as a failover and not for load balancing as per Netgate’s documentation. I have tried that method before and it didn’t seem to work either when I gave that a try.

You need to setup the firewall rules correctly, add the extra firewall rules first so that you restrict vlan access and RFC1918 networks

Add the BalanceME gateway to the ‘Default allow Lan to any rule’ only - as this is your internet outbound traffic rule - this will use your load balancing setup.

1 Like

That seems to work, I’ll keep an eye on it. But pretty promising, thanks!