Installation Pfsense on HP T620 +

Hi complete newbie here,

I been watching the excellent video on networking & pfSense which is now loaded on HPT620+ thru bridge mode on router thru a switch . After trying out on a VM in unRaid . Installation was good until i tried to connect unraid to pfsense . The unRaid server is running HA (IOT)& cameras running on network 192.168.0.XXXX running fine. I am unable to find a solution to transfer the IP’s to the pfsense router 192.168.1.xxxxx.

I assume that i have to connect directly to modem /router for pfsense to allocate IP?
Or is there another way so that i do not lose my configuration for the various IOT etc.

I appreciate that this may be a stupid question, but any advice would be appreciated.

You can change the LAN IP of the pfsense to match your current network, you can do this during the install or it can be done after, just remember when doing it after you will also need to change the DHCP range.

Thanks for prompt reply, i received an error IPv4 192.168.x.xx/24 is being used by or overlaps with Wan 192.168.x.xx/24, The reason being is that this is how i access my router. I did say i was newbie so i must be missing something.

Thanks in advance

Ideally the pfsense should have the WAN bridged to the ISP provided devices and everything should be downstream of that.

Why are you obscuring private IP ranges? This only makes it unnecessarily difficult for us to provide detailed help.

Anyways, as Tom already said, the modem doesn’t have to be in the same subnet as your LAN network in order to be reachable. Matter of fact, many cable modems are automatically switching to an IP in a different subnet, e.g, after you turn on bridge mode, exactly for this reason, to avoid IP conflicts like that. If yours doesn’t do that, the easiest way would be to leave it on it’s default IP, e.g., and change the subnet of your LAN to another subnet, e.g in pfSense.

However there are a few scenarios where the modem might not be accessible from another subnet:

  • If you have removed the default “LAN to any” rule, or if you have rules in place that are blocking traffic to other RFC1918 subnets, you have to set an explicit “allow rule” for the IP of your modem.

  • There is a possibility that the modem only allows connections from IPs in its own subnet. If that’s the case it gets a bit more complicated, but the following post in the Netgate forums should help you with that: Cablem Modem Access - Behind Pfsense | Netgate Forum

Thanks for your reply, i believe the problem is that i have a SKY Broadband Router which is unable to go into Bridge Mode , therefore i believe it is Double NAT. I am due to have fibre installed in the next couple of weeks so i will be changing providers , therefore i will get a normal Router which i will be able placed in Bridge mode or you a Modem to connect directly to pfSense pc. I am learning all the time after looking at all of the Lawrence Video but could figure out this situation.
Thanks again but i amy be back in a few weeks

Ah ok, then in probably makes sense to wait…

However, if you want to start playing with pfSense already, It is absolutely possible to run pfSense behind a router with NAT. Tom does this all the time in his lab setups for his videos. I was running a double NAT setup myself for a while before I started using pfSense and it’s imho a legitimate setup if you e.g. want to have a simple network segmentation with consumer routers (poor man’s DMZ as I call it :wink: ), or if you want to use your own router behind a provider router that doesn’t allow bridge mode.

In order to make it work, you have to uncheck “Block private networks and loopback addresses” and “Blocks traffic from IP addresses that are reserved for private networks per RFC 1918” on pfSense’s WAN interface and assign a fixed IP address to it that is inside the LAN subnet of your provider router.

PS if you have one of the old BT FTTC modems around, you can use that instead of the sky router and connect it to the wan port of pfsense

Hi I have a HG612 BT Modem, which i unlocked a few years ago and used it with Apple Time Capsule it worked fine. I have connected directly to the Wan port on pfsense however i am not receiving an IP address only the on the Lan Any ideas on a solution

hi, its all about the odd way sky authenticate over vdsl using dhcp option 61…

in interfaces > wan > DHCP Client Configuration > hostame … you have to put…


i just used my nowtv routers wan mac address…


i also put the same mac address under “general configuration” above … though prob not needed


HI , Thanks now up and running pfsense from Modem - pfsense router. Now the fun begins. Moving everything over to the pfsense.

Thanks again

I hope that you could give me some advice on how i can install my unraid server into pfsense now that i have pfsense connected directly to ISP as you suggested. I have looked at so many videos on here i baffled ? unRaid is on my original network whereas pfsense setup is on internet-modem-pfsense-switch-laptop. DHCP lease showing Lap & switch.

Any idea on how i can connect unRiad I understand that i have to have unRaid in the same network?

Your advice would be appreciated.

hmmm. i dont use unraid, prefer proxmox, networking wise, i just assumed when you swapped out your existing nowtv router u would just give the pfsense the same LAN ip address as the router with the same dhcp range etc… and your away?

I thought the same Wan & Lan have Dhcp , back to the drawing board.

I have been able to install pfsense using a modem in bridge mode - pfsense -switch , however i am struggling to find a solution to install my unraid server to pfsense. I have 2 spare Nic which i could use but following the installation of OPT1 with dhcp enable , and installing into this NIC still unable reach the unRaid server as it not showing in dhcp releases do i have to change the ip to the NIC IP for an address ??

I am not sure what i am missing

Any advice or direction where to look would be appreciated.

just read ur first post … personally I’d start “easy” and only go to multiple nics after…

  1. reset pfsense and rerun first time wizard and change LAN IP to and enable dchp on LAN, and configure WAN as before

  2. connect ur unraid server/cameras/pfsense together using a switch

  3. start up all your cameras/unraid server etc…

Thanks I will try your suggestion .