Idrac 7 Dell R720 cannot connect from browser

I recently purchased on ebay a Dell poweredge R720XD. I have tried everything to get the idrac 7 to work. Initially the license was missing and it would not allow me to select a dedicated NIC. I downloaded the idrac local license tool and installed an enterprise evaluation license with a usb drive, this allowed me to select a dedicated NIC. I have tried DHCP and static ip. i can ping this idrac ip but nothing else. I have tried chrome, IE, and firefox. I have added it the the security in java but i just cant get it to work. any help would be appreciated

Have you installed the recent firmware update?

DRAC with Lifecycle Controller v.

I figured out how to fix it after toooo much searching but glad i fixed it
root@’s password:
/admin1-> racadm get idrac webserver
ERROR: RAC917 : The syntax of the specified command is not correct.
See the command help text. To see the help text, run
"racadm help "
/admin1-> racadn get idrac.webserver
status : 2
error : 253
/admin1-> racadm set idrac.webserver.enable 1
Object value modified successfully

i was trying to ssh into it but i didnt have the passkeys set up. then is used racadm to get in and enable webserver. works perfect now