How to import an ISCSI LUN from a TrueNAS Snapshot in xcp-ng


I have:

3x XCP-NG host in the same pool

they are connect to a Truenas with ISCSI and Multipath is activ on all of the server.

I have create a new zvol from a snapshot of my iscsi zvol.

when I want to connect the LUN to my xcp-ng I keep getting an error:
“DMP failed to activate mapper path”

Just want to restore a vm from a snapshot.

I tried to connect the target to another xcp-ng, there I can’t add the target without formating the volume.

anyone an idea?


I have never tried to do it that way, try their forums

Are you connecting the zvol clone one of the three servers in your pool?

When a storage repository is created a UUID is generated to be used for the naming of the SR on the backend. If you do a ‘pvs’ from any of your hypervisors you can see this. I think what is going on is that there is a conflict adding the SR because of another SR existing with the same UUID and name on the backend.

If you have some spare hardware around you could try and connect a freshly installed XCP-ng node to your cloned zvol SR and see where that gets you.

Hope that helps!


The conflict with UUID was the issue.

End up with using another xcpng and it works.