How To Build XO From Sources on Debian 10 Using XenOrchestraInstallerUpdater

Did you follow the instructions from the error “Please see logs for more details”?

Bringing this back to the top, this method (ronivay) seems to work fine on Raspberry Pi 400 (4gb) running RaspberryPi OS and doesn’t seem to be very slow. It took about the same as other real hardware installs I’ve done on “low end” hardware. Probably about 20-30 minutes worth of waiting. Need to connect it to my lab network and make sure everything works.

Moving to Debian since CentOS is going the way of Open Solaris and I like having it on bare metal so I can burn the XCP-NG system down and start from scratch easily.

Not sure if anyone has run into this issue. Trying to do this install on a Ubuntu 18.04 LXC container on my QNAP NAS and was getting, an error at line 213 of the install script, " add-apt-repository command not found." I tired to use apt install and it failed

Was able to resolve with the command below

sudo apt-get install software-properties-common

Hope the rest of the install goes without any issues

Some useful hints. The video is still very valid in Sept. 2021.
Here are some helpful changes
The config now allows to create the ssl cert as part of the install script. Just look at the readme on the github.

If it has been a while since you did this and you try to do it from memory. Make sure you don’t use the wrong installer on github. There is a repo suggested by searches that is three years (as of writing) out of date… no commits. Use the one in this thread and you’ll be okay - does what it says on the tin. The repo has pretty regular commits. (You might think of donating to the dev, you can virtually take him out for a beer… heck buy him a round for his friends as well 'eh? Or maybe he likes boardgames send him enough euros to buy a boardgame).
watch a quick vid on Vim if you don’t know it already
watch a quick vid on tmux if you haven’t already. tmux-learn-linux-tv.playlist

Observation. Although I gave this many cores I think 4 or 6 is more than enough. I rarely saw it use more at one time. Both in all my installs in the last year+ I see core 3 peg and then the other 15 cores rarely get used. Not sure how efficient Yarn is at using multi-core … I am not a dev. It certainly uses some. Also RAM 4GB is enough - I first tried 16 and it didn’t touch it. If you look at Toms FF in the vid you see similar result.
currently updated successfully to xo-server 5.82.1 xo-web 8.87.0

I don’t update. I just create a new vm and install from scratch every few months. The updater feature probably works, I have run into issues in the past and find it faster to just follow Tom here in the vid and roll it anew. I find xo from the sources seems to run more smoothly this way.

Hope this helps someone!!

~0m
Everything looks to be patched home>hosts> select host(s) > patches tab > “up to date” = yes

1 Like

Sorry for sounding stupid, but two questions regarding this topic.

First, do you have to create a Debian VM on your XEN box to have access to the XEN Orchestrator or can you just run the installer on a separate Debian box.

And secondly, if can run the install on a separate Debian machine, how then do you get the Orchestrator installed so that it can connect to the XEN server?

I had previously built the Xen Orchestrator on my Debian box and at one time during a previous Xen test, had it working so was just wondering if all I had to do was connect to it (how??) .

Thanks.

Yes you can run it on separate computers, that’s how I have mine set up and how I installed it on the RaspberryPi 400-4GB. I would recommend more than 16GB for the system drive if you use a standalone computer for this, I have an HP T630 that runs my XO and the 16GB ssd that came with it is basically always full with just enough room to upgrade to newer versions while deleting a previous version.

To connect you need to log into XO and add servers:

Settings → Servers and fill in the IP and user:pass, might want to toggle the switch for “unauthorized certificates” unless you have installed real signed certs., otherwise the connection will fail.

If they are already in a pool, you can just add the pool master.

Greg_E thanks for the reply. It’s what I thought was the case, but the instructions were a little ambiguous. I’ve only been testing XCP-NG and up to now, have created an XCP-NG VM for Debian and the XO build. I think what I’ll do is put the XO on a separate piece of steel and use it from there all the time.

In the link that Tom gave, there is also a way to download an XO from sources appliance directly into your XCP-NG, it seems to work fine the one time I tried it. But I also really like having XO waiting when I burn my XCP-NG system down and start from scratch (twice now). It’s just nice having choices.

I didn’t see the link that Tom gave! Is it in the video? Anyway, I’ve just finished building XO on a separate low end spare box and connected it to my test XCP-NG server. As I said, this is just a test. If I like what I see, then I’ll buy a new server class box to use it on, but at least now, I have the XO built and running.

I’ve played with XO a bit but still prefer XCP-ng Center. Probably just a learning curve thing.

Thanks for your help.

There are a few things that Center will do that XO won’t, can’t remember off the top of my head but a couple of things.

Since I’m really new to this stuff and after watching the video and going to ronivay/XenOrchestraInstallerUpdater on GitHub, I noticed there is an install script on the readme page if you don’t want to first install a VM and then use xo-install.sh script on it. It’ll download a prebuilt Debian 10 image which has Xen Orchestra and XenOrchestraInstallerUpdater installed, and will install the VM and setup XO on it. I went with this method which in my case worked well.

Hello,

I am a fan from Tom’s its video’s like this one. Since a week I am playing around with Xen / XCP-ng / XenOrchestra and it is clear that the free Ochestra version is … limited. So I decide to build the full version myself. Inspired by the video. However I am facing a couple of issues. So I need some help.

I am using the latest XCP-ng build and among other things I did create an Debian11 VM which I also use to build Xen Orchestra. The VM has plenty of RAM 16 G, plenty of vCPU 8 and pleny of Disk 35 GB.

So I watched the video, did read the related page and tried to build. However … I did not yet manage :japanese_ogre:

  • I discovered that you can only build if you are root (no issue, however not mentioned)
  • That tmux Cntr-B + " does not work (minor, I just opened another window)
  • And than … WARNING: free disk space in /opt seems to be less than 1GB. Install/update will most likely fail !! :skull: and that is where I need help !

Problem is as follows:

  • the 35G virtual disk is divided into multiple disk (by the Debian Installer) and on one of these disks is … ^/opt^ … however despite a lot of ^google-ing^ I have no idea to which ^/opt^ is pointing to :frowning: :frowning:
    So I do not even have any idea on which "virtual partition^ ^/opt^ is situated. And I am not happy with that :face_with_hand_over_mouth:

So I have two questions:

  1. where is ^/opt^ ???
  2. how to change the size of ^/opt^ !!??? which probably imply how to change the size of the involved partition

Louis

I’m not sure if this is a XO question or problem – more of a partition problem. When you installed Debian I’m betting the installer probably allocated you a very small /opt partition – just a hunch. When trying to utilize this partition you’re basically using the entire space. I guess this is all falls back to how you setup your disc partitions during installation – either manually or automatically. You might want to revisit your disc partitioning scheme(s). Usually for me with my VMs if I’m not using one big fat / partition, I’m using a separate /boot partition, / = system partition, and possibly a /home partition. The separate /boot partition is more for UEFI since whatever partition it boots from needs to be formatted FAT32 and the the other partitions are what every scheme you like – ie ext4, ext3, etc.

kevdog,

I just overlooked the /opt when using ls. That was problem one :frowning:

Second problem is that by default the Debian11 installer creates partition sizes which are IMHO / for my purpose “not at all OK”

Since I am normally a windows user not a Linux user, I did query the internet to find out how to resize a partition. Did not make me lucky.

So I decided to throw the VM away and create a new one with a manual defined partition schema. I do not like at all the Debian installer expect you to do that (why is the stupid thing, not simply ask the user which size the partition should have !!?? etc)

Whatever I will manage :slight_smile:

Thanks

Hi @LTS_Tom and everyone in the community.
Quick Question…How about an updated video tutorial on this very topic? Who’s with me on this kind request to Mr. Tom?
An updated Walk-through would be very nice.
Thanks to all for your time.
Cheers!

What’s wrong with the current one?

Hi @LTS_Tom thanks for the kind reply.
Well, I created my VM and followed your video back in 2020, and did not update ever since. I know, my bad… Now, when I run the xo-install.sh and choose option 2 (to update)…message says successful update of xo-server and xo-web. However, when I try to open the GUI with the IP of the xo-from-source VM…the GUI does not load anymore.

I am thinking something breaks during the supposed update.
And, I resort to load XO Free so that I can revert the VM snapshot of Debian 10 XO From Source back to the 2020 version. This is the only way to get the GUI up and running again.

I can’t figure out what could be happening and going wrong, which is why I came back to the Forums to request some feedback. And, maybe an updated video, since the github page has been updated a while back also.

Anyway, thanks for your time and support Mr. Tom and our great community.
Cheers!

There is not anything different here in 2022. Yes, there have been updates and new versions of the XenOrchestraInstallerUpdater project but the process is still the same. If you are so far behind and can’t figure out what is broken then just build a new VM using the same process as in my video.

1 Like

Hi @LTS_Tom thanks for the kind reply.
I have done as you suggested, AND can CONFIRM for the whole community, that following the steps in the video do give success, still in 2022! Even when using Debian 11.2 netinstall ISO. Thanks Tom for all the advice and for even checking the Forums on a Sunday! You are truly a great tutor to follow.
Cheers!

1 Like

You would need to pull the latest scripts to be able to just run the install script to update.

Git Pull is the command you are looking for (or at least them one I’ve been using), this will merge in the new parts of the install script.

Alternate is delete and clone the git again which will give you all the newest scripts.