Help with SAS Driver


I have an old Dell PowerEdge R610 that I need to load Red Hat9 but since version 8, Red Hat has remove all drivers for older hardware from the ISO.

The R610 as LSILogic SAS1068E-IR SAS card in it (Dell SAS 6/iR). Could anyone please tell me where I can find the driver for this card for Red Hat 9?
To start I tough this was part of the SAS2008 familly and tried the drivers from [this repo]( but it didn’t work.

Could anyone please assist me?


The Red Hat KB asked people to replace the card but is there not a way to load the driver manually?

Hi all,

I found this repo, could nyone please tell me if the SAS 6/IR is a Megaraid or SaTA?

Thank you

Based on your article you posted it looks like it isn’t supported. I personally wouldn’t try to hack my way into making it work either.

The vendor / device ID of your card is 1000:0058, according to this list:

And according to this list here: - dd-mptsas would be the matching driver package.

So I would try one of these:

dd-mptsas-3.04.20-1.el9_0.elrepo.SHA256SUM.asc 2022-05-19 14:06 348
dd-mptsas-3.04.20-1.el9_0.elrepo.iso 2022-05-19 14:06 718K
dd-mptsas-3.04.20-2.el9_1.elrepo.SHA256SUM.asc 2022-12-06 19:23 345
dd-mptsas-3.04.20-2.el9_1.elrepo.iso 2022-12-06 19:23 740K

Hope that helps.

@bb77 I cannot thank you enough for going through all the details above. I have now managed to load the correct driver and I can see all the HDD during the installation.

You just saved my bacon :slight_smile:

1 Like

Glad it worked out.