Help getting some printers working

Hey everyone.

To start I have very minimal knowledge of pfsense, firewalls, and routers. I am here to learn and learn by doing. So talk to me like I am 5.

I am starting a homelab/server and I purchased a xg7100-1u along with a unifi nano ap and some used server equipment to start causing myself a lot of sleepless nights but should have a lot of fun in the process. The unifi is not setup yet. I currently have my old asus rt-ac88u on ap mode for wireless.

I run a business and one thing I really do not have time to figure out is how to get my printers working on the network so I was hoping someone could point me in the right direction to get setup.

I have a dymo labelwriter 4xl and an old brother 2240xl. (Invoices and Labels) These are hooked up to some io gear usb print servers.
https://www.amazon.com/IOGEAR-1-Port-Print-Server-GPSU21/dp/B000FW60FW

I originally purchased a cisco switch but it arrived damaged so the only options I have to plug these in right now are my actual xg7100 or that old asus rt-ac88u that I have set in AP mode while I figure out the unifi nano ap and get a new managed switch. I have tried plugging these into both the netgate and the asus and cannot get anything to show up for dhcp lease (i dont see them show up anywhere to do anything with them). When I plug these into the eth ports on the xg7100 the lights go orange.

Any help getting these up and running would be really appreciated.

Your print server probably has a default IP address. You’ll need to inspect the manual, then the plug it into an unmanaged switch along with your laptop then assign whatever IP address you want.

I just just checked out the manual.

Just says to plug it in and get the ip address assigned to by dhcp and then go to that address to set it up.

On the DHCP leases page in pfsense, nothing shows up when they are plugged in on either the asus router in AP mode or the pfsense box. No ip is assigned.

I don’t have any Netgate devices but I do believe you have to configure the ports to act as a switch, easy to test, plug in your laptop if it gets an IP address then you know what to troubleshoot.

Did the USB printservers come new, or obtained from someone/somewhere else?

If not new, they may have been statically assigned - and need to be reset to facilitate the DHCP addresses:-

Disconnect the Ethernet cable and any devices connected to the print server. With
power still connected hold the reset button for ten seconds. While continuing to hold the
reset button unplug the power from the print server, continue holding the reset button for
another ten seconds. While continuing to hold the reset button plug the power back into
the print server and hold the reset button for another ten seconds. At this point you can
now release the reset button and unplug the power from the print server again. Allow
the print server to sit for another ten seconds, plug the power back into the print server.

Perhaps then they will obtain an address automatically and appear in the listing for you to address them.