Having a hellavuh time with Port forwarding

Hi there all, I’m relatively new to pfsense and am learning slowly, but I’ve hit a snag which I have absolutely no idea how to remedy.

So I run a bunch of DCS servers (it’s a flight sim) and I use an add-on called dcs-gRPC which requires ports in the range 50051 (TCP) - 50056. It only REQUIRES 50051 ( but I run 5 of the servers so I need all 5 open).

However I go to NAT set up a port forward as I would normally, my WAN IP is a public DHCP ip provided by Comcast. I have my lan/gateway setup on a 10.10.1.X address.

So in the port forward section I have selected wan address, to ports 50051 - 50056 TCP, with the starting port at 50051 and the local IP address of 10.10.1.120 (the server that runs the dcs-gRPC client)

I think this is the way you should setup port forwards on pfsense from what I’ve read, but no matter which NAT or reflection settings I choose (Ive tried all 3) any port checker I use to test if the port is open on my public IP all say it’s closed.

Like I said I’m not the most experience networking guru and hope someone can offer some advice as I’d really like to get this sorted.

Thanks in advance and let me know if you need more information , screenies etc (I assume u will)

Good to be here been a long time watcher of the YouTube channel first time poster.

This is what I’m using to check ports are open: https://portchecker.co/




Oh boy you certainly have a setup !

You might want to view this vid How To Setup Port Forwarding on pfsense 2.4 - YouTube it should set you straight.

If you have multiple ports you can also use an alias, it will keep your rules to a minimum, make it easier to rectify errors, as well as adding additional ports without changing anything else.

I notice you have forwarded 1194, gotta say, I don’t do that for openVPN, I add those ports to the WAN rules to allow my openVPN traffic.

Does look like you are having a hellavuh time :woozy_face:

I’ve been using pfsense for a few months and recently forwarded a port. As far as I can tell your setting match what I used. I’ll be interested to see what the issue is.

So I managed find some TCP ports that were listening (but they are completely different to the ones the grpc dev suggests to use so we will see if they do-no reason they shouldn’t right?) What’s weird is it seems no matter what I do my router just refuses to forward 50052-50056 yet it manages to do 50051 just fine, weird.

You might want to troubleshoot this locally first. Are you sure when you do a port scan locally you can reach all the ports you specified? Have you checked to see if the firewall on the server is allowing inbound connections to those ports?

Yes the ports are open locally in the built in windows machine (the server). How would I do a "local"port scan? I’ve been doing port scanner.co using my public IP, so you mean just use that but put in the servers local IP instead?