Harddrives not showing up

I have some WE Blue drive i would like to use for a home Truenas. WD60EZRZ. The problem i have is the computer does not se them, not in truenas not in bios. Have tried everything obvius like chaning SATA ports, power etc. They are old drives from a friend and did work nice in his “on board computer raid nas.”
i have tried them in another system as well with no luck.
i do feel the discs spinning up.
it is ASUS motherboards i have tried them on, one intel one AMD.
The same system does se other WD drives, some WD Red i have. no problem there. it is just the blue ones.

Anyone have an idea??

Sounds like a dead drive?

yes, but at the same time they do spin up, i can feel it. and i did get them from a friend and they did work fine for him. and i did get 4 drives from him, and it is the two that are exactly the same that behaving like this, it is not impossible they are dead but at the same time it feals a little bit wierd.

Dead drives can spin up. A dead drive does not mean it won’t spin up.