HAProxy Not Working

I bought a domain name from Go-Daddy and tried to setup acme and haproxy for reverse proxying some services but it doesn’t seem to work. I have followed multiple guides on YouTube but nothing helped. When I try to connect to the specific subdomain it gives me 503.

Full Disclosure this is a very new territory for me and I have never worked with domains before so it is highly likely that it is my fault. I have followed 3 videos one from LTS, and 2 others and nothing seems to work.

Any Ideas on how to go about this.

503 most likely is that is connects to the front end but the back end connection is not responding.

I am not sure what to do, I am totally stuck. The acme certs are working but it doesn’t connect me to anything. I thought it might be go-daddy’s dns so I switched to cloudflare but that didn’t work either. My current setup is the domain’s A record pointing to go-daddy’s IP because I don’t have a static one. CName www pointing to the domain and the CName I want to use is pointing to my NOIP’s dynamic dns. I have followed through all 3 of your videos about HAProxy and tried everything and a few things from other creators too but nothing seems to resolve the 503

The error is now changed to 502. I am not sure where I am going wrong. Do I need to manually allow cloud flare ips? I am also running pfblockerng so I am not sure if that might be causing the issue but it seems unlikely because I have already forwarded 443 to the firewall so all https traffic should be going through