Guest wifi getting different IP from DHCP

Hi Mate,

we are currently having problem regarding our guest wifi network. Our Router/Firewall is Fortinet Fortigate that is also our DHCP server. Then we have Ubiquiti Controller and 2 access point for the wifi. Then 2 swtiches, DLink 48 Port Gigabit, POE, DGS-1210-52MP and DLINK 48 Port Gigabit DGS-1210-52. below is the diagram for your reference.

I already setup the Guest Wifi in the Fortinet with VLAN-100, with the unifi also vlan-100

and also with the device in the switch Vlan 100. But upon connecting to the guest wifi account it is giving 169… IP not the one we define in the DHCP server.

If the client’s displays an IP addr starting with 169.254.x.x it means that it wasn’t able to get a valid IP from DHCP.

Check your VLAN tagging on the switch ports. 90% of the time you just forget to tag a port.

hello mate,

do i need to tag also the port of the cloud key?

The cloud key doesn’t need any tagging. You need to create the Network on the controller with type VLAN only. Then you need to select that network in the Wifi configuration. Then you need to check that the same VLAN is defined on the fortigate and than you need to tag the ports on the switches in trunk mode to allow the traffic for VLAN 100.

1 Like

do i need to reboot the the switches? i already tagged them i think properly wait i will try to screenshot.

Hello mate these are the settings for the switches to i need to change something?

Switch 1- port 50 is the uplink from firewall to switch, port 52 is the uplink from 1st switch to 2nd switch

Switch 2 configuration - port 50 uplink from the 1st switch, port 45,47 the two AC’s

To trouble shoot, I would set a port to untagged VLAN 100 and plug something in. It should force that port to VLAN100 and see if you get an address. You can try that on each switch and work your way to/from the firewall.

hello Mate,

i was not able to untagged a port, i tried to assign manual ip to my laptop then insert it one of the port tagged vlan = 100, this is result.

and this is the unfi configuration.

Hello Jeff,

I have same challenge with Guest Wifi coming on VLAN.
Only difference is Router/Firewall is Untangle -
DLink Manage Switch 48port
DLink Manage Switch 24port POE
DLink Manage Switch 24port POE

I will be happy if you able to solution around. you follow your steps.

Unifi UAP AC Pro’s
Cloud Key Gen 2

how are you troubleshooting mate. some of us are having problem if the device is from different manufacturer. :joy:

This advice is right on. When you are on your Unifi controller in the network app > settings > networks, the guest network needs to have “VLAN only” selected within the “purpose” section with your 100 VLAN specified in the VLAN section. If you are trying to select some other type of network things may not go as expected unless you have Unifi switches.

Besides that it’s just about making sure every port that your 100 VLAN touches is tagged or trunked and selecting that network in your WiFi settings on the Unifi controller in the network app > settings > wireless networks. Dont forget that the AP itself needs to be on the same VLAN as the controller so they can talk which means that the AP port on the switch will likely be trunked as well as the switch uplinks (although if you have a lot of VLANS maybe just select the necessary ones).

Good luck!

Jeff,

I am still stuck winding around.
I will follow EX approach to see result.

Thanks