Getting Windows10 ARM to print on Kyocera

I recently purchased a Lenovo Yoga 630 with Windows 10 for a client. He has a kyocera mfp. He runs most of his business through a third party over an rdp connection (I know …I know!) so he didn’t require a beafy spec’ed machine. I didn’t realise at the time that it came with a Snapdragon ARM processor.
It actually is quite snappy but I’m having great difficulty finding drivers that will work with it. I know windows10 has 32bit emulation and apparently 64bit is on the way but when I try to install the 32bit using the emulation…it fails. I’d like to get it running on Windows 10 first and then I don’t know whats going to happen with passing through the printer over the RDP connection.
I’m just wondering if anyone has encountered a similar problem and maybe has a proven workaround?

A coworker had the same type of situation, didn’t buy a thinkpad, there was an option to print via android / ios wifi of some kind but she couldn’t get it to work, eventually just copied the file to a USB stick and stuck it into the USB port on the printer.

Thanks @neogrid. This is for a business so that’s not a viable solution.

Are they printing on the host laptop or in the rdp session? If through rdp they shouldn’t need any drivers as long as the remote computer has the driver installed.

@njongstra they can print locally but not in the rdp session. The printer suite of applications will not load on the laptop (probably because it’s not compiled for ARM) but I can setup the printer manually. The company hosting the rdp based program use a bit of middleware called ScrewDrivers specifically for making sure that drivers are picked up by the rdp session but they spent all of yesterday morning trying to get it work and they couldn’t.
I might just have to bite the bullet, admit defeat and order a replacement (non-arm) machine.