Getting started with XCP-NG

After hearing about XCP-ng I thought I would give it a try. I’ve installed it on to an old desktop as a host and I’ve been attempting to install Ubuntu (Gnome) just to test things out. I’ve tried to create two separate VM’s. First I tried 19.04 and it would lock up during the installation from a local ISO. I figured since the template was actually for 18.04 there might be some compatibility issues so I did a proper 18.04 (gnome) installation. The installation worked but I can’t successfully boot. Attached are images of some information from the host, as well as where the VM locks up on boot. The last displayed boot message links to problems with GPU’s however Google usually links me to people having issues with nvidia cards, whereas this host has a Radeon in it. If I enable ‘VGA’ on the VM the boot still hangs but on an orange screen instead of the other text boot, probably at the same part of the boot sequence.

Anyone have any insights or additional questions?

I have never tried it with a Radeon card and most all of the machine we have this on server builds except the demo machines. Check their forums as they might have more ideas.

Additional image post as a new user

Did you install the tools? What about driver in 18.04?

Tried to mess with nomodeset, changing the greeter to lightdm, pulling the dGPU etc. Ended up giving up on making Ubuntu working, there are other reports of people with this issue, both with Xen and other hypervisors. Ubuntu server of course works. Tried Windows, CentOS and Debian and they all worked properly with GUI so I’m just going to toss this up to an Ubuntu specific issue. Now that it seems to work for me for everything else I’ll give it a practical spin and try moving some of the other stuff I run from home off of the host instead.

I also tried the installing the guest tools, but to no success.

I’ve hit a snag where I’ve created a local ISO SR. It’s now full and I can’t find a way to expand it. Some posts mention to simply use a file share as an ISO source but there must be some way to expand the capacity for local ISO’s on the host. Any tips? I could simply shuffle ISO’s around but I’d rather understand how I should be properly doing this.

The local ISO SR should be as big as the drive you set it to use. If you used the Dom0, then it is quite small, only about 4 GB roughly in size. It is not recommended to use that, as it could cause system problems. If you used Dom0, then I would suggest removing that local ISO SR and supplying the ISOs from a different drive. Then when you specify another drive as the local ISO SR, it should see the full size of that drive/partition.

Thanks for the clarification. Only after I messaged I realized that xcp-ng had only partitioned 20GB from a 1TB drive for itself and the hypervisors storage was filling up, not just the local ISO storage resource. I could have booted from a live CD and moved partitions around but I gave in and just attached a remote ISO resource since that is so much more elegant of a solution.