Gateway disabled after reboot

I’ve been testing site to site Wireguard VPN. I really like it, however I have one issue. When I reboot the one of the routers the gateway I created for the static routed is disabled. I have to manually untick the disable box to get the VPN active again.

When I reboot the router on the other side all gateways are active.

Both routers appear to have the same config. There is nothing in the logs.

Can anyone help with this issue? Thanks.

Think I may have found a solution.

When I change the Monitor IP in the gateway settings to be the IP it’s own interface IP (instead of being empty, the other side of the VPN interface IP or being marked as alway up) the gateway starts after a reboot.

I’m facing the same issue though my setup is a bit different. The three sites are all behind NAT (the ISP itself NAT the connection) so all the three sites are routing through a Cloud VPS. I tried following your advice by setting the monitoring IP of the gateway to the tun_wg0 interface IP and disabling the gateway action, but it doesn’t work for me. Also tried disabling Gateway monitoring but still the same issue.

What I believe is happening is when the firewall halts or reboots, it stops the WireGuard service, and in the process the Gateway associated with it gets disabled, the same way if you uninstalled the WireGuard package.

However, upon booting back up it doesn’t gets enabled automatically. This is my take on this issue. Hope someone can find a solution soon as I’m scratching my head over this.

I’m still having this issue. Seems to be more intermittent now. The same problem has been raised here: Bug #12808: Wireguard Gateways disabled when Wireguard Service is Manually Restarted - pfSense Packages - pfSense bugtracker