From firewalla to pfsense

Hello all first time post. Learning the ins and outs of what seems to be a gothic sized task. My upgrade from firewalla was primarily because I couldn’t get my full 1Gig up and down. Everything worked perfectly with the firewalla other than speed issues.

Currently i’m using PFsense 2.7.0.a.20230127.0600

Mostly everything is ok. Speed is fast, most all port forwarding works. But what i’m having trouble with is I used to play a game called RISK of RAIN 2 with my friend and it lags so bad, up to a min and I’m just dead when i spawn. Yikes. So, I port forwarded all the UDP/TCP to my static IP gaming machine. Still does it. So i checked the system logs and it’s blocking UDP/TCP from my friends computer in Japan. It’s part of the default deny rule set. So I allow these UDP/TCP via Easyrule, same result. Since I’m so new to pfsense, I don’t think i have a full understanding of what is going on. And googling this topic always ends up talking about UPNP. Which i don’t believe is the issue. I’ve also tried to enable UPNP, didn’t work.

Other issue is, no matter how hard I try to get OPENVPN working, i just cannot connect to it. I’ve gone through other Youtubers methods, and also LTS on how to get it to work. Please note i’m using the wizard like everybody else. I’ll keep trying…

Any help is appreciated.

Is your system getting a public IP for the WAN? Also to help with OpenVPN we would need some logs and errors messages.

I used to play Risk of Rain 2 multiplayer and never had a problem with a vanilla install of pfSense. Unfortunately these days by myself I can play solo (just played a solo game without issues), naturally I can’t test multiplayer while solo.

although I spent most of the time in this game dead…

Yes sir it’s public. All i have to do is witch back to the firewalla and everything is great. I didn’t pull the logs before switching as i wanted to have fun with the friends. I will pull the logs and post them in here when i move it back over. Everything else works quite nicely. I’m just not as savvy to understand what is going on unfortunately. Thanks for the reply

yeah, it’s a pretty fun game. Just lastnight when i move back to the firewalla we played for 2 hours. My buddy hit 570million damage on artifact mods 112 min long… yikes

So this is what i have for port forwarding. I failed to mention also I do have snort/PFblocker installed with sub ruleset. IT hand not occurred to me that could be suspect as well. I figured port forwards would supersede Snort/PFB. I’m like babes in Toyland here, I’ve never had so much granular control over a firewall in my life. @LTS_Tom Do you have a video on basic understanding of how PFSense works, a primer so I could possibly answer/understand the many questions I want to ask but refrain.

I don’t have a log atm as it’s long since passed on the GUI, have to wait for another gaming session to get it again.

I’d also like to mention, I tried to use a VPN so we could play together. I figured everything could be incapsulated and passed through the encrypted tunnel. No inspection would occur. Didn’t work at all.

This was my desperate attempt to make it just pass the data from him to me.

I just tried to start plex and got bombared with UDP blocks. Same thing happens when i try to play games. It took 2 min before plex finally gave up and i could use it.