Fresh install of xcp-ng on a PowerEdge R430 fails to create VDI

So I loaded xcp-ng on a PowerEdge R430 yesterday utilizing 4 x 8TB SAS drives put into RAID utilizing the PERC H730 Mini. I have another PowerEdge R430 with the same hardware other than it’s utilizing 4 x 4TB SAS SSD’s rather than mechanical drives which is working without issue.

Here is the error I’m getting:
SR_BACKEND_FAILURE_78(, VDI Creation failed [opterr=error 22], )

I’ve tried reinstalling the OS twice now, rebuilding the RAID array as well.

I have an xoa controlling all 4 of my xcp-ng hosts and I utilize xcp-ng center as well on one of my VM’s

Any advice would be greatly appreciated! Thanks :slight_smile:

You get then when you are trying to load it?

I get this error when I’m trying to create a new VM. Doesn’t really matter what capacity I’m allocating.

On my other PowerEdge R430 utilizing SAS SSD’s in the same RAID config the VM creation works just fine. Other than drives these servers are completely identical.

Did you choose EXT for local storage when setting up the system? How much space shows free on your local storage?

I believe it was set to the default, so thick provisioned. According to both xoa and xcp-ng center there is 14.5TB available (Type is LVM)

I just reinstalled xcp-ng this time selecting EXT and the results are the same, same error when trying to create a VM.

Is telling you that the storage is not available. Anyone who has had the issue come up before here in my forums had solved the issue with a reload. You could look for clues as to what my be causing the error in /var/log/xenstored-access.log

If no one else here has any ideas try posting in the XCP-ng forums Home | XCP-ng and XO forum as well.

Thanks Tom! I’ll head over there :slight_smile:

I had just got these servers from a new client when we upgraded them. It turns out they were never updated. A few odd errors were accruing as well. Spent a few hours getting everything up to date and performed another clean install. The issue appears to be resolved now.