FreeRadius Server not starting

Hi, This is the second time i tried to install FreeRadius on a fresh Pfsense. I just received a 2100 from Netgate. Had the community version on it. We updated it and it went to 21.02. We installed FreeRadius and setup the server and noticed the service was not started. We tried to restart it and failed. Looking at the logs we see this.

Apr 6 12:52:46 radiusd 92963 Debugger not attached
Apr 6 12:52:46 radiusd 93393 Unable to check file /usr/local/etc/raddb/certs/server_key.pem: No such file or directory
Apr 6 12:52:46 radiusd 93393 /usr/local/etc/raddb/mods-enabled/eap[26]: Failed parsing configuration item private_key_file
Apr 6 12:52:46 radiusd 93393 rlm_eap_tls: Failed initializing SSL context
Apr 6 12:52:46 radiusd 93393 rlm_eap (EAP): Failed to initialise rlm_eap_tls
Apr 6 12:52:46 radiusd 93393 /usr/local/etc/raddb/mods-enabled/eap[2]: Instantiation failed for module eap

We tried to uninstall and reinstall with the same message. This happen before and i copied over the server_key.pem from another Pfsense and the service was able to start and no more issues.
Anyone else seeing this? Thoughts? They were both Netgate 2100 that i saw this.

Just a thought …

that first error looks like a cert can’t be found, perhaps you used the default certs when installing the package. Netgate says not to use those and create your own, I only know this as I tried it and could not get it to recognise the ones I created. Under Certificates for TLS you ought not to use the defaults.

You have the latest pfsense perhaps look at the change log perhaps there are some things to be aware of since the update.

Not an issue I have run into, but we upgraded people that already had FreeRadius and I don’t think any of my staff has added FreeRadius to a new 2.5 install yet. You should post this in their forums.

Thanks, will reach to them.