FreeNAS SMB speed?

I was wondering about this:
I am seeing near full Gbit speed when doing an iPerf test from my FreeNAS to my MacPro running Mojave. (or the other way around)
Also when using the Blackmagic test I see around 100MB/s read/write speed to an SMB mount.
However when bulk-copying files I see roundabout 70MB/s writing to the NAS.

Do these figures seem reasonable? Why only 70MB/s when copying files vs. the 100MB/s doing the write test and nearly 125 using iPerf?

Many thanks!

I am by no means highly experienced with FreeNAS but …

When you were achieving about 70 MB/s copy speeds - what types of files were you copying?
The reason I ask is because when transferring a large number of very small files, the transfer speed drops significantly.

For context my FreeNAS is configured as a mirrored pair of 4TB drives and is connected to a Gigabit network - so I too should be able to achieve near line speed when transferring files. That being said when transferring many small files, I often see much slower speeds. When I am transferring larger files such as a folder of RAW photo files (about 20-30 MB each) I see much closer to 100MB/s but still not gigabit line. I believe I recall that when transferring video files that are several GB each, I’ve seen speeds in excess of 100 MB/s. Overall anything about 75 MB/s or quicker is fine for me until I make the 10GbE upgrade.

Thank you for those numbers! I never see anything over 70MB. Even when transferring a single 30GB QT or MXF file, 70 is about the absolute maximum I’m getting. Looking and the network reporting the LAG statistics is hovering at slightly over 500Mbit tops. Looking at the graph it seems like speed has never gone over around 550Mbit.
I understand that SMB probably has quite a bit of overhead for whatever it needs to do on the side but just a bit over 50% of what the interface is capable of I found slightly surprising. Will do some more testing, from what you wrote I could be seeing significantly more.
At the same time Blackmagic test goes up to around 100MB (no matter if I set it to 1GB or 5GB test file) and iPerf is nearly at 1Gbit

What kind of drive is installed in the endpoint testing your NAS? Your HDD could be the bottleneck. And I am assuming you are running over a wired connection and not wireless right?

I am copying from an internal SATA drive (WD Black, 7200rpm) which tests out way beyond what the network connection is capable of.

My main question is: Is 70MB (a little over 50% of what the network is capable of) or should I be seeing more? What’s the top speed to be expected with SMB over 1Gbit? I’m sure I won’t see the full 125MB/s in practise but 70 seems a bit disappointing.

Here’s a bit of history statistics of the LAG interface. As you can see it’s only ever a little over 50% of what it could do.

I’ll setup NFS and FTP to compare in the next days.

How do you determine the network speed when transferring files? I presume if you are a Windows 10 user you simply look at the “more details” when copying a file where it shows the speed? If there is a better easy way on Windows or macOS then I will give it a try on my system with a few large files and folders of smaller files to confirm that the results I mentioned before (from memory) are accurate.

I primarily use macOS. While copying/moving files to/from a NAS macOS does not show transfer speeds, so I often do not know how quickly the file is transferring. Not to mention - I have a USB-C hub attached to my MacBook Air that provides ethernet, HDMI to 4K screen and SD card slot. It definitley not ideal to transfer pics from my SD card to the NAS since I’m quite certain that I am being bottlenecked by the 5Gbps limit on the USB-C dongle I have.

When copying from the Mac I can see the speed in activity monitor under network. Also the sync-tool I use show the speed while copying to the NAS. Both figures match and the ingress speed that FN shows for the LAG confirms the numbers (see the screen shots I posted earlier). I am not using any network dongles. These are transfers from internal SATA drives to the NAS (details in earlier postings). The only thing between my desktop and the NAS is a Cisco SG300 switch but as mentioned iPerf reads near full 1Gbit speed both from FN to the Mac and vice versa. Together with the 100+MB/s read/write speed I get from the Blackmagic speed test to the mounted SMB share, I can only guess this is some kind of SMB specific issue?
Found a few postings on the freenas forum of users with similar numbers. I guess I’m not alone. Tried a few SMB tuning settings but no real improvement so far. It seems to be even worse on TrueNAS which has made me stick to FN so far.

Running TrueNAS Core right now and transferring a 7GB ISO I’m getting 108-113 MB/s on Windows with a 1gbe client.

My NAS is linked at 10gbe but the client is 1gbe, so it should be similar.

My SMB performance has been pretty consistently at / around that mark since I built the box from what I can remember.

R510 with 12x 4TB disks, 4 RAID-Z pools.

It could be a limitation of Mojave’s SMB implementation or its interoperability with FreeNAS’. Could you try something like an NFS share?

Tried an NFS share. Write to NAS is 50-55MB/s (50% slower than SMB) read is 107MB/s (same as SMB or slightly faster) via Blackmagic test.

Then tested APF. 100MB write 107 read (same as SMB) via Blackmagic test. Interestingly and unlike SMB when copying a large file to the NAS the speed is the same as measured with BM speedtest (100MB) so very much unlike SMB where I test 100MB but when copying I get 70MB tops.

Still significantly less than the 110+ most people are seeing…


Do you have any network overhead going on in your environment?

I’ve got Dante (audio over IP) running but turned it off for the test. It only uses a few kb anyway. And even when it’s on iPerf always tests out slightly below 1Gbit in both directions. No difference in performance between Dante on or off. Next step: rule out the Cisco SG300. But since iPerf is always at almost 1Gbit I doubt the switch is to blame…