FreeNAS SMB share with domain and workgroup computers

#1

I’m running FreeNAS 11.2-U1 in my church and recently connected it to Active Directory. Now the SMB shares only work for computers joined to the domain. I’ve tried the shares set up as Windows mode (with DOMAIN\administrator and DOMAIN\domain admins permissions and added modify for Everyone) and Unix mode (world writable). Neither works for workgroup computers (mostly Windows 10, but also some Macs). I’m allowing Guest Access, but it’s still prompting for a password when trying to connect – and guest/smb doesn’t work.

0 Likes

#2

I recently ran into FreeNAS SMB share issues myself. For me, the shares were view-able and editable on Linux, but not on Windows.

I encountered the same issue on Windows 10 trying to allow guest access, it just doesn’t want to work. Windows expects to provide a username and password. I wish I could tell you the exact steps to resolve your problem, but the best I can offer are thoughts on some things to double check and look into:

  • Check that the workgroup name is the same on FreeNAS and members of the domain (workgroup setting for FreeNAS is under Services->SMB Settings
  • Don’t bother setting your user account as a “Microsoft Account”, it’s not needed and may be causing unnecessary problems.
  • Get Guest access out of the mix, I understand you were using it as a troublshooting method, but it obscures the real problem since Windows doesn’t like non-credentialed access
  • Check your user permissions on the Windows machine
  • Try logging into the share not with the credentials of the user you created, but using root credentials (this is what I did that finally got my SMB shares to open)
  • Try running through the entire dataset, and SMB share setup process again if circumstances allow, being very slow and methodical about your settings (It’s amazing how easy it is to make a glaring omission that messes everything up).

And you should absolutely watch the videos here, they go into great detail about how permissions work in SMB and how to set it all up correctly. In fact you should watch that before even bothering with the suggestions I made above.

0 Likes

#3

If you join your freenas in a domain workgroup does not work as it says on the smb service icon help.

Must match Windows workgroup name. This setting is ignored if the [Active Directory] or [LDAP] service is running.

So what you gotta do for workgroup pc is just say the credentials as NETBIOSDOMAIN\USERNAME and not just username.For example if your freenas netbios name is FREENAS you would add a windows credential as this User: FREENAS\username password: supersecurepassword
and it should work.

1 Like