FreeNAS SMB mount problems


#1

Hi, i’m on my first freenas setup ever, created a disk and a share, user, permissions and everything according to Toms grate video. It is an windows share so i can access it from both linux and windows.
The problem i have is when i try to mount it in Linux mint (18.3)
i just get: “Error: Failed to mount Windows share: Connection timed out
Please select another viewer and try again.”

though i can mount the whole freenas disk and get the complete file-system for that server. with the root account that is. i have tried al the samba fixes i can find, the service is running as it should.

any suggestions wold be appreciated.


#2

i did an update in the smb.conf file to force the samba to use smb2 or smb3. after that i can access the shares from the GUI. but i can still not mount the shares.


#3

ok, i did solve it my self.

the problem was the SMB version. i added “vers=3.0” to the end of the mount command and it worked fine. maybe the post help someone else and therefor i post the solution in my case.
//xxx.xxx.xxx.x/share /home/user/test cifs username=username,password=password,vers=3.0,uid=1000,gid=1000


#4

Thank you for keeping us informed. Good info!! I’ll keep this in mind when I create my first FreeNAS machine.