FreeNAS 11.3 Replication - poor network transfer speed

Hi all,

I have two HP Micro N54L servers running 16Gb of memory and an onboard gigabit network card. I have, thanks to Tom’s video set up multiple datasets and setup snapshots and replication between the two using SSH without stream compression. All good really pleased. However watching the network performance it is pegged at about 95 Megabits/sec The CPU is not struggling it fluctuates about 15-20%. If I use SMB transfer and just copy a file to a dataset I can get ~300 Megabits/s still not in Gigabit territory but nearly 3 times the Replication speed.

I was thinking of switching to a non-SSH transfer to see if the SSH thing was the issue (thoughts?) and the SSH+Netcat seemed like an option. However that option opens a whole bunch of additional configuration dialogue boxes.

So my questions are:

1 - Is SSH likely to be the reason for my poor LAN transfer speeds. I don’t need a permanent secure transport as my replication target server is still in my house just a different part. I need the transfer speed to increase and especially as I’m doing a lot of data take on. I could switch to SSH later.

2 - If that is likely to be the case, has anyone tried the SSH+Netcat option how stable is it, did you see a noticeable increase in speed?

3 - Can someone walk me through the SSH+Netcat configuration please and go slow on the port selection part as I’m not familiar with port selection, is just “pick a number any number” or is there more to it? Also is there a need to do any config to the Target machine? Primary is - Target is

Many thanks in advance

Tom keep up the great videos

Sorted, there is some choke point in my network. Tried the transfer with two Cat6 cables and one gigabit switch and it jumped into life.

RESOLVED. I went through everything and there were two dead cables in the Cat5e between the two machines. One cable was not seated correctly another was snapped at where the outer sheath had been cut to reveal the twisted pairs…soo 1000 was running at 100 but still running! It could have been like this for years.

Thanks everyone who chipped in.