First vlan, I need help

I hope this will help. I am trying to setup a vlan, move my wireless from flat network. to I gave up on the camera’s, If I can get one setup I hope I can figure it out. Maybe the TP-Link is the problem. Probably the operator!


Create / Define the same VLAN ID in pfsense, UnIFi and probably the TP-Link and then create the proper rules in pfsense.

Thanks, watched it many time…I get lost in the switch config. I just don’t know how to config the tp link. If i select port 1 on the tp link in the vlan I loose access to pfsense. I have been trying to set tp link vlan port 1 and 6. Believe I’ve tried all selection: tag, untag, so on.

It’s not that difficult but it will be easier if you have the final design in mind then implement it.

What I’d suggest is the following when it comes to your vlans.

Keep your LAN on, add the following vlans with the subnets


Configure PfSense with the above Mr Lawrence has several videos on vlans.

On your switch, reset to default settings. With TPLink I think they are on Change the IP address to, give your laptop a static IP on the 10 subnet, then configure the vlans on the switch. However, 1 or 2 ports need to be a Trunk, these connect to your pfsense box, you can create a LAGG if you have more than one port on your pfsense box. Assign 3 ports to the 3 vlans on your switch, you need to have a look at the manual for the precise steps.

Then connect your switch to your pfsense box. If your pfsense is correctly configured then connect to each vlan over DHCP you should be assigned an IP address.

Depending how you have configured your rules will depend what you can see between the vlans.

Hi, OP.

I assume on Pfsense, you have created the VLANS you desired and assign em1 on all those VLANS (also for now set your firewall between VLANs to be allow any any to avoid any issue in regards to firewall). For port 1 on your TL-SG3216 switch you need set to Trunk and if it gives you an option what VLAN number that is allowed to pass-through the Trunk you need to indicate that as well. Once you have done both, by default the traffic should start traversing.

Thanks guys, I am holding my breath, it is working now. I have watched the video’s many times. I had everything setup correctly with pfsense and unifi. It was the switch!

Thanks again