Erratic backup behavior on XCP-NG & Proxmox

Hey guys. I’m not sure if any of you use Microsoft’s ActionPack subscription but apparently next summer they’re taking away the product use rights from the program (aka killing it if you ask me). As a result I’ve had a renewed interest in a Linux-based hypervisor. Half of my stack is already Linux based and I’ve been growing leaps and bounds in Linux knowledge this year due to using it on my laptops and distro-hopping in the lab.

Anyway, all that said I put together a 3 node hyper-visor lab with a few desktops I have laying around. They each have a 256gb SSD, 16gb of RAM, and an i5 CPU. I got XCP-NG running pretty quickly (thanks to Tom’s videos!) but as I dug into the features to test things I started running into issues - particularly with replication and backups. First, if I used XCP-NG Center, I could migrate a single VM and it would work perfectly. Whenever I tried to migrate a second one though, it would never give me the next button to continue. If I closed and reopened XCP-NG Center, I’d be good for one more and then the same thing would happen. I tried Xen Orchestra. It would fail when I’d try migrating. If I rebooted the hosts, I could get one to migrate but then no luck.

Next I dug into the replication and backups section of Xen Orchestra. Replication never worked even once. Backups would work one time, then fail. Fed up after spending hours Googling and only finding info about old bugs that were patched by now, I wiped the lab and installed Proxmox instead. It has a lot more familiar interface to me than Xen Orchestra but its backup facilities are seriously gimped in comparison to what XO offers. That said, I kept getting timeout errors trying to restore a 3gb VM, deleting a clone, etc. It just feels like out of the box stability leaves an awful lot to be desired. I’m going to test with an R720 I have in case it’s just the low end hardware I’m using but for now I may be springing for a Windows license next summer.

In Tom’s videos, he sings the praises of XCP-NG a lot and I really wish I could get it stable enough to trust it but if it fails that bad in a lab scenerio for me, that scares me away from using it in production at all! Just for clarity, I didn’t post the exact error messages since this is a lab and I’ve blown it away a few times. Not looking to do in depth troubleshooting yet - just wanted to test drive the features. Anyone else have similar experiences to me on this type of thing? Sorry for the rambling!

There are many large hosting companies using XCP-NG but if you are having issues, there forums are very helpful

Most of the installs we have are on enterprise hardware and work very well, but I have tested it on other consumer system and it works as long as the hardware was supported in CentOS.

Hey Tom,

Thanks for the reply. I decided to give XCP-NG another go - but this time I went with 7.6 instead of 8.0 beta (yeah shoot me now for trying a beta, LOL). Worked perfectly fine this round. I’m a bit baffled. Anyway, when you’re working on your 8.0 lab, any chance you could let me know if replication works for you? I’m curious if that’s a bug in the beta…

Most of the lab testing we did with 8.0 was with ZFS and drive pass through. We did load and move some VM’s over to it without issues but I did not test the backup on it yet.

Interestingly enough, XCP-NG Center still has the same issues with only allowing 1 migration but XO is working perfectly now. The interface is growing on me but still wish it were laid out in a little bit quicker fashion to get from VM to VM. Thankfully the interface is really responsive.

I’m thinking the issues I had may have been related to me messing around with pool settings. Nuke and Pave of the whole thing got me back to basics. I’ll stick with 7.6 till 8’s been out for a while as a release then give it another go in the lab. Going to play with backups to FreeNAS next.