Edge Switch 48 VLAN

I have a PfSense build out with 5 networks one of these VLANs is 100 GuestNetwork.

Port 41 should be Vlan 100

Port 49 is the 10GB uplink to the PfSense
Port 50 is a Trunk to a 10G 24 port switch

This is my first UBNT switch so the VLAN tagging seem different. I followed your guides on youtube and not sure what I missed.

LAN (lan) -> ix0 -> v4: 192.168.1.1/24
GUESTNETWORK (opt2) -> ix0.100 -> v4: 192.168.10.1/24

Now I thought we would want to untag port 49 and 50 for both default VLAN and GuesNetwork. However, the Switch doe snot allow me to set port 49 to U for vlan100 if default vlan 1 is set to U

Normally the Uplink and the Trunk ports are set to all VLAN’s unless you exclude.

Any idea?

In doing some deeper reading, looks like maybe the VLAN taggings for (ix) is disabled? but I just tried it on an (em) unit and seems to have the same issue.
https://docs.netgate.com/pfsense/en/latest/book/vlan/index.html

Ethernet interfaces with VLAN hardware support:

ae(4) , age(4) , alc(4) , ale(4) , bce(4) , bge(4) , bxe(4) , cxgb(4) , cxgbe(4) , em(4) , igb(4) , ixgb(4) , ixgbe(4) , jme(4) , msk(4) , mxge(4) , nxge(4) , nge(4) , re(4) , sge(4) , stge(4) , ti(4) , txp(4) , vge(4) .

Ethernet interfaces with long frame support :

axe(4) , bfe(4) , cas(4) , dc(4) , et(4) , fwe(4) , fxp(4) , gem(4) , hme(4) , le(4) , nfe(4) , nve(4) , rl(4) , sf(4) , sis(4) , sk(4) , ste(4) , tl(4) , tx(4) , vr(4) , vte(4) , xl(4) .

I don’t have an IX network card to test with, but make sure you are following the edge guide for VLAN setup

I was able to get the setup working, I was doing the tags backwards. ixgb(4) = ix0/ix1