Duck dns hostname and pfsense issue

Hi everyone,
I signed up duck dns free service, then I tried to setup an OpenVPN server on my pfsense 2.4.5 machine.
According to their instruction here:
https://www.duckdns.org/install.jsp (see pfsense setup)
I needed to choose " dyndns services and select custom service ." in the pfsense ddns configuration page, which doesn’t enable me to set a hostname as it does by selecting different ddns service like NO-Ip (which I used once with no problem at all)
Ok I went on until the OpenVPN client export step.
I had to let “Host Name Resolution” blank:

But when I tried to export a configuration I got this error message:

I don’t know what to do now since, according to their guide, I have to set the “custom” option for duck service, which in turn doesn’t enable me to set their domain assigned to me.
What did I get wrong and how can I fix this?
Thank you

can’t see how you will be able to get OpenVPN to work without a hostname.

Just use NO-IP seems to work well enough or one of the others already loaded in pfsense.

Exactly.
No-IP works great, but I was looking for a DDNS service without any time limit.
I need to confirm NO-Ip account every month.
Thanks

ah I see, I might look into that, I use NO-IP but it would be handy not having to renew each month.

Now I see that the hostname field isn’t present in the custom option on the DDNS service, seems like a catch-22 situation.

Exactly!
I had to give up Duck dns service finally, I’m now using securepoint dns, A German free DNS service with no time limit apparently.
Greetings

I used this guide, I think I had to have a couple of tries at it, and I can’t remember what I did to get it working. But it works very well when my son tested it

He also has a run through on his youtube channel.

I’m going to look at the site you posted anyway. :slight_smile:

Hopefully this helps.

The actual issue is if you try to set up a DDNS service using the custom option the hostname field is not present. If you choose any of the bulit-in DDNS services the hostname field is present.

I know this guide, and I had set No-IP already on another pfsense machine.
Thanks anyway.

Yes, I know it, and I didn’t understand how to overcome it

Ah right, I did it with Duckdns I’ll have a look at my config. I can’t remember whether it was the certs or openvpn, I’ll reread the article again.

I just signed up for the spdyn and plugged that in pfsense, can’t have to many dyndns :slight_smile:

for the openvpn server part under ‘client export’ and ‘client connection behaviour’ - select ‘other’ under host name resolution and then the hostname field will pop up and fill in with your duckdns host name. has been working for me for a long time.

dont confuse openvpn with dynamic dns section. the dynamic dns part is to keep your public IP address up to date if it changes - just needs your ‘update url’ as per the duckdns instructions, host name not required.

not sure if you resolved the issue but thought it may be useful if anyone else stumbles accross this issue.