Dual WAN failover DNS problem

My goal is to use my mobile phone LTE connection as second Internet gateway in case of problems with my cable connection.

I watched Toms video about the topic

It works almost.

I use dns resolver on my pfSense maybe this is a problem with dual failover?
Wen i disconnect the cable network connection it failsover to the LTE connection as it should.

In a Windows command box i can ping ip’s but dns is not working.

If i test “nslookup google.com” this works also but the default DNS, the pfsense lan ip doesn’t work to resolve dns requests.

I tried everything i could think of but sadly no go.
Maybe somebody here on the forum knows what i could have overlooked?

Just a guess, in the Resolver, perhaps you have to select the 2nd WAN in the outgoing network interfaces.

I selected the second wan in de resolver outgoing networks.
To test i enabled “DNS Query Forwarding”.
I have several (Quad9) dns servers configured in system > general setup.

Wen i manually configure a dns server in my windows client network settings it works i can surf the net.
If i set the network settings to auto it doesn’t work.

Make sure under “System General → DNS Server Settings” you have the gateway set to none and under “Services → DNS Resolver General Settings → Outgoing Network Interfaces” you have “ALL” chose.

I did all that but still no dns.

I stopped snort, i stopped pfblocker while testing dual failover.
I checked the firewall log
But nothing that could give me a clou of the problem.

Every dns query i did against the pfsense interface gives a not found result.
If i do “nslookup google.com” it works.

Seems some problem wen unbound is in between.

On the dns forwarder , have you check your outgoing network interfaces.

Is ‘All’ select, or just your wan interfaces - try changing it to All

I am using “dns resolver” (Unbound).
Yes i did set ALL on outgoing network interfaces in dns resolver settings.

It is really wierd it is not working.
Such a great option to failover to LTE wen my cable modem is down.