Draytek Vigor 2860n+ Firmware Update Gone Wrong

Hi, I’ve been desperately trying to reset/upgrade the firmware on my Draytek vigor2860n+, all the network of the company I work for relies on it and 20+ VPNs now. I updated last night to the version, it was on I did it using the web interface, somehow, when the router got rebooted it wasn’t working anymore, it doesn’t connect to the ethernet, only the DSL led stayed on and sometimes the 3 left ones start blinking, already tried to do a factory reset and update via Firmware Upgrade Utility v3.6.10, sometimes it goes well as it should, even says the router is active, but never works, pings or anything else. Their support staff just recommended to use the firmware upgrade utility, but I’m screwed until I can revive this one. We just use the ISP router to pass the ethernet to this one.

Any help would be so much appreciated, the healthcare institution I work is in a worry

Last post from this forum:
For Draytek, any time you see the 3 lights on the left restarting everything 30 seconds -it’s the PSU.


every time I turn it off and on, the DSL light stays on and after some 5-10 minutes, this only left 3 start blinking, and no matter what I do, try multiple firmware updates via tftp on different ports, they never turn off or back to normal again. Also, the only ports that get on are the LAN 2-6, the wan2 and lan1 never gets on, how do I know/test the psu on these?

Just try it with a different PSU, its quicker than trying to make a break-out cable for measurements… It should be on the device how the plug is wired (center +/-) along with the voltage and current required. Match the voltage, current no less than stated(higher than required is fine for current).

1 Like

already tried 5 different psus, same result :worried:

Are you allowed to pop it open? At this point the only thing that could give some clues is a serial port, which it seems it has:

It seems you will need a 3.3V TTL adapter.

1 Like

is the serial port internal? that means I have to flash it with this wrt firmware? I’m kidding new to the deep dive in routers, thanks a lot for the support, products without good support or a community are worthless

Speaking about support im surprised it only has an internal serial connection only, to top it off its a TTL one too… Regardless it should work even with the factory fw, but you will have to guess for the correct speed(two common value is 9600 and 115200)

1 Like

what are even talking about bro :rofl::rofl::rofl: I feel so dumb rn

Okay, first up

Then RS232 vs TTL:

On the openwrt page i linked there is an image showing where the internal connector is with the pinout (just go down until you get to the serial section). That uses a TTL serial signal which means you cant use any standard serial cables:
(Just at random from google.)

Now the only question remains is the speed since usually these use 8 data bits, 1 stop bit, no parity, and XON/XOFF for flow control.

And i am suprised because most business level stuff has an external serial connection.

1 Like

thanks alot for the explanation, I knew what serial port and rs232 was, but I didn’t know that I could use pins as a port. The 2 usbs port doesn’t work for flashing?

All the info i could find only describes the tftp method, the usb’s never mentioned as an option…

1 Like

yes, me too.
Apperently, my router is international and I upgraded using a UK fw, didn’t notice, my msp says it doesn’t matter (it isn’t the fw fault), I reached draytek international, they pass it on to my country real support and they’re working out a way with the UK team to unlock it. They say the problem is on the UK fw that blocks the router.
Every help article on the UK site you have to swear your from that region and creat an account, mean while to download fw’s that block the same routers from other regions is wide open and the first suggestion…