DNS issue for HAProxy via OpenVPN on PFsense

Hi everyone.
I’ve already tried asking this once but I had no luck….maybe this time some kindly person can help me.

I setup an OpenVPN server on pfsense following Tom’s Video for remote connection to my home network. It works fine.
I then setup HAPROXY server on pfsense following another Tom’s video. It works more or less…but let’s say it works.

My problem is that if I’m connected via the OpenVPN connection in order to reach my NAS and phone PBX and other services I must enter a DNS record (pointing to my HAProxy) both on the local firewall DNS resolver and also to my account on cloudflare. In his video he explained that one entry DNS entry is enough but it doesn’t work from me.
Can anybody help? I wold like to manage my dns just from one side….

If they are internal DNS names then you need to push them to the OpeVPN clients. The push settings are in the OpeVPN server settings under “Advanced Client Settings”

I tried that but it didn’t work…
I’m sure That for you is something easy but it’s really driving me crazy…
I watche your HAProxy troubleshooting video befor asking… I really don’t understand what I’m doing wrong…