DLink DGS-1210-52 switch vlans with pfsense or edgerouter

Has anyone been able to get vlans working on an edgerouter x or pfsense with dlink smart switches? I say “or” because I’ve tried both. Currently working on an edgerouter.

The dlink interface and their terminology is complete garbage as is their documentation, so I can’t seem to get them working quite right. I’ve got the vlans setup in the edge router or in pfsense with dhcp servers and all. I know all that is correct. But, when it comes to the dlink’s web interface… man what a mess. I can get vlans setup but in terms of tagging and untagging, not a member, pvid settings; all that, I can’t seem to get it working right. Should be as simple as settings trunk port from the router (Can’t find ANYTHING that shows how to set that. Some of the older firmware or other switches have a section specifically for this, these do not.). And then set what ports are tagged/untagged and set the PVID for the untagged ports… No dice… Issue being no ip address given out to client on untagged port that isnt vlan 1.

Any help would be appreciated! Or just happy thoughts. Whichever you are willing to give. I dead.

I don’t have any DLink switches, but I downloaded the manual ftp://ftp2.dlink.com/PRODUCTS/DGS-1210-SERIES/REVF/DGS-1210_SERIES_REVF_MANUAL_v6.10_WW_EN.pdf

The VLAN setup starts at the bottom of page 44.

It looks similar to the TP-Link TL-SG108E vlan setup.

To define a trunk port you have to add that port to every vlan you want the trunk to be a member of.

You can select only a single untagged vlan for a single port. For the untagged vlan, you must define the vlan to associated untagged traffic on that port with the PVID.

What have you tried to do?

Can you post the interaces section of the ER-X config?

I.e. output of CLI commands
show interfaces | cat

Then redact any global ip addresses if you want to.

Yeeeah, we ended up getting it. Turns out for some reason the switch just wasn’t pulling the tagged vlans from the edgerouter. We moved the uplink cable to another port and then back and everything started working… HA

Gotta love technology!

Thanks @BuckeyeNet