Desktop VMs Compatible with XCP-ng (Migrate away from VMware)

Hello Forums!

Considering moving away from VMware ESXi for the home lab for weeks now and there appears to be a gap in tooling: Desktop VM hypervisor that is XCP-ng compatible. My current workflow:

  • Create VMs via VMware Workstation (on desktop)
  • Copy VMs from desktop to ESXi - and vise versa
  • Use VMware Workstation to download powered down VMs for backup purposes
  • Run VMs on Desktop or ESXi (fully compatible)

The current gap is what compatible hypervisor for the desktop works for XCP-ng that would replace VMware Workstation?

Aware of Oracle VirtualBox and VMware Desktop to OVA exports. But there are compatibility issues switching from VMDK to OVA, xen-utilties vs open-vm-tools, etc. The current impediment preventing me from switching from ESXi/workstation is the tight integration between the two. There are no issues with licensing, as the free ESXi licenses are fine for home use.

Anxious to hear other VMware to XCP-ng migration stories too. XCP-ng looks like a great hypervisor and I want to give it a go, but will miss being able to leverage desktop compute resources.

I don’t think that you can continue your current workflow, though it sounds it just covers the creating of vms.

I’ve been using vmware since the start of the century and Workstation is a great tool, I don’t think other desktop alternatives come close.

When I tried to migrate some vmware vms I had, to Proxmox it was a complete pain, in the end I bought a cheap box loaded ESXi for legacy vms I have and a backup for my vms which I run on my laptop.

Created from scratch the vms I use on Proxmox, those vms stay there.

Perhaps there are better migration paths from vmware onto other hypervisors now. However I haven’t seen better alternatives to Workstation.

1 Like

There is not a similar workflow with XCP-NG. I create all my VM’s inside of XCP-NG and the only moving I do is between lab and production servers. I have a video on how I move them between hypervisors as we do have many clients that migrate over to XCP-NG


Thank you both for these replies- it helped.

After ~6 hours of messing with XCP-ng and XO had no luck getting even a local SR created from a local NVMe drive attached. Using XO, the SR was always creating with type “iso” even when “local” was picked. The device was given too “/dev/nvme0” per the documentation. In all cases the system would not format the SSD to ext for VM storage. Switched the system ESXi and the same drive formatted fine to VMFS datastore and is taking VMs flawlessly.

Going to stick with ESXi for now and perhaps give XCP-ng another try in the future. For right now, the “it just works out of the box” experience of ESXi free and Workstation fits the use case for the home lab.