Dell R510 Raid Controller

I picked up a used R510 for “playing” purposes. The raid controller it has in it is already flashed to IT mode. A buddy of mine that I’m having help set it up to play with is saying i need to reflash the controller back to Dell mode so the controller can do the raid controlling instead of the software.

My thoughts to play with it are to load XCP-NG to learn VM machines…hopefully to eventually move bare metal servers at my office to VMs.

What is everyone’s thoughts on the raid controller…leave in IT mode or flash back to Dell?

Thanks in advance

It depends, Is it for storing the actual VMs? or Storage for the VM’s use?

If it is the first case, just make sure XCP-NG can use the RAID card.

If it’s the second case:
If you are using ZFS, it actually hurts to use a “hardware RAID”, as ZFS needs direct access to all the drives to warranty data integrity.

Afterall, “hardware RAID” is actually software RAID, running on a piece of hardware you don’t have complete control over it.

Not sure what it will actually be for. Might/probably will be both VMs and storage as the unit has 14 bays. I’m looking at the internal 2 as raid1 for the OS and then the hot swap 12 as VMs and storage.

But this is all new to me, so I’m not sure which route to go.

If it’s for “playing” it really doesn’t matter much, except for what you want to experiment and learn.
Normally, (in my opinion) you want to separate the VMs from the storage.
The processing node or nodes, has lots of RAM and CPU power, and almost no storage. (just for booting the OS).

The storage node or nodes is a storage solution like FreeNas. The VMs run from the first node(s) and write all their data to the storage node(s). (the storage is not inside the virtual machine).
That way your VMs are very small (in size). This make them faster to manage. (backup, restore, copy, etc.)

1 Like

Leave the HBA in IT mode that way you can run FreeNAS and learn ZFS most value for SMBs. Boot from a SSD or USB when running tests makes switching OS easy. Grab a 2 or 3 cheep SSDs (Micro Center has good deals) and learn Proxmox, XCP-ng, FreeNAS, pf-Sense. Have a R-610 that I run evals on including Linux applications for client demos. I have both a flashed HBA and the H700 that came with the box.

1 Like

I left the card in IT mode and tried installing XCP-ng last night. When booting from the usb to install, it saw all the drives. But once installed and booting without the usb, it didn’t find the drives…thus no bootup.

From talking to Mr. Google, it looks like the card needs to be flashed both the hardware and the bios. The card came flashed with the R510, so i’m not sure what/how it was done. Is there a way to check?..and remember, this is my first foray into non-ms stuff. :slight_smile:

Just to followup and note my resolution in case someone else searches for the same problem.

I posted on reddit also and got it figured out. Turns out i needed to get into the setup of the card and tell it to boot from a specific hard drive. (i’m guessing it’s because i was using a drive that was not “first” in line for the boot order)