Dell R220 Help with troubleshooting

Good evening, my R220 died on the 4th. here is what it does, upon being plugged in it ramp up the fans for a bit when thy go off. the motherboard green LED is on, but nothing happens when the power button is pressed.
so here is what i did.
removed anything not need to boot.
resented ram
pulled the CMOS battery
i don’t have a iDRAC and all get on the info screen which is just a few LEDS is a yellow power symbol.

so i ordered another power supply and just installed it and i still get the same result.
so do i have a dead motherboard? I don’t see any damaged caps and I don’t just want to order a motherboard there not cheap. there almost what i payed for this server a year ago.

any ideas what i can do next? I am really missing my Pfsence box

Try pulling all the memory except the bare minimum, typically one or two sticks, and retest. Cycle through all the memory in that fashion, if it still fails, then consider the cpu or mb.

2 Likes

I just tried that and reseated the CPU still the same, bummer

If you’ve gone through all the memory, and no change, reseated the cpu and hs, then I’d say your probably looking at a m/b issue as you’ve already replaced the p/s. I’d pull the board, pull everything off, and closely inspect everything on it. Somethings probably burned or corroded, inspect any testpads and traces as well. If everything looks fine, then I’d test the power connectors for shorts. Pretty random, but possible to happen.

It’s always cheaper to fix it yourself, if you’re able of course.