Dell G5 Desktop

Purchased a nice Dell G5 5000 desktop with the i3-10100 10th gen processor as a new hardware solution for a firewall, added in a 4-port i350 gigabit card and installed fresh copy of pfSense 2.5.1. I see my 4-ports (igb0-3) but not the onboard (which I actually need - I needed the 5 ports, lol). Dell’s site does not list any drivers other than Windows and I get the impression it’s using the Killer 2400 or similar hardware. Anyone had any experience in getting that interface operational???

My guess is that the on board NIC is realtek rather than Intel? Or another unsupported NIC

Yep, I may be able to compile some realtek drivers, the joys of having Multi-WAN and multi LAN requiring 5 interfaces!!!.

Could you not use the single LAN interface to a little managed switch, and then pass vlans through that?? , i.e. using the managed switch as interfaces instead??

It’s something that requires PHYSICAL separation, doesn’t respond well to VLANS - doesn’t play well with others, lol

It would be though, wouldn’t it?? If you set those ports on the mini switch to untagged, it would be the equivalent of a physical interface on the pfsense?? I may be wrong, but that was my understanding?

Of sorts, but not quite what I need, reasons not to put onto a local based switch for fear of ‘alteration’ and ‘mischief’

Fair enough haha :slight_smile: - tbh I used a realtek adapter on pfsense before on a VPS… it worked, but it was VERY slow, and latency was shocking… changed to an Intel adapter and all sorted itself out… just don’t think pfsense likes realtek :slight_smile:

I tried enabling the Realtek, and no-go. It’s a Killer Ethernet interface. The Dell site only has Windows 10 drivers. I’m trying to see about the ndis conversion but my firewall does not have source file loaded and I haven’t yet found a way to load subversion on it to finish the compile. May just have to build a FreeBSD host to do the nitty-gritty on and see about loading the .ko driver afterwards. I have 4 of these bad boys so NEED it to work as I gave up on my Firebox units when the IPSEC kept dropping after several days and they said it wasn’t a bug as they didn’t support the hardware, lol. Now, gone to a wonderful G5 5000 and still can’t get something to work…!!! HELP!

Killer ethernet… isn’t that Intel?? Aren’t they also 2.5Gbps?? Maybe there’s some BIOS setting that can be changed?? Maybe even downgrade to 1gbps until pfsense have the drivers for it?? Honestly don’t know what to suggest as haven’t personally been in that position myself.

The Killer appears to be Atheros, usually available from the ALC section, but not present on the 2.5.1 build from what I can see, as the Atheros Wifi is also not visible. I was trying to get that to load to provide some form of test but nada…