Dell Constellation.2 drive firmware without Dell server?

Here’s a question that keeps rolling around but that I still can’t find a good answer.

I have some old Dell Constellation.2 drives for my lab, running these in an HP server. I tried the Dell updater tool, but it says this is not a Dell product and quits. I just tried again in an old Dell R710 and the windows tool says the system is not compatible with the application.

I do have the firmware extracted from Dell.

Is there a way to force the upgrade without a Dell server? Is there a way to force these drives back to the Seagate configuration or modify the firmware so the Seagate updater will flash them?

The end goal is to hopefully upgrade them from 3gbps SATA to 6gbps SATA to match the other drives in the server (Truenas) and bring the entire pool speed up to 6gbps speeds. As far as I know, the firmware is the only thing holding these drives back.

Specific model number is ST9500620NS

Found 4 more of the “newer” 6gbps version for $8.80 each shipped and just bought them. But would still like to experiment if anyone has some ideas to try.