Connecting HP and Unifi switches via SPF

I have a network that has two HP 1820 switches at the core. There are essentially 5 vlans. 1,10,20,30,40. Vlan 1 is on the HP switch and is the managment vlan, but is not used. All of the switches are on vlan 10 from an ip perspective. I have two outbuildings that are connected to the core via fiber. I am trying to replace old switches in the outbuildings with unifi 16 port 150w switches. Plugged the unifi into the switches into the HP switches via ethernet to configure them, and everything was successful. Moved a switch to the other building, no connectivity when spf is connected. Verified gbic compatibility. Tried defaul All vlan on spf port, tried setting mgmt network to vlan 10, set another profile to all vlans with vlan10 being the default network. No connectivity over the spf ports? Any suggestions? I’m about to pull my hair out. Thanks.

Did you get the fiber connectors crossed?

I don’t see how. I pulled the fiber out the old switch and put it into the new switch. It is an LC connector. The connection works when it is plugged into the old switch, but now when plugged into the unifi.

I can confirm that in general HP switches and Unifi switches do talk over SFP. I don’t think I have those two specific ones used anywhere but as a general priciple.

Have you tried connecting via SFP with the unifi sitting right on top of the HP using a short lead?

Does the link come up but you get no traffic or do you not get any link?

Wrong (SR <-> LX) or non compatible SFP vendor?

Did they show “link state” when you plugin the fiber or does it stay dark?

Yes the link light is lit. It is green and blinks indicating activity. However, no traffic appears to pass.

Ok, so almost certainly a L2 issue.

Without wishing to cause offence… How happy are you with VLAN config generally. Is it something you do every day or is it still a bit of a learning curve?

My logic would be to one copper port on the Unifi on a vlan that has DHCP, connect the unifi to the HP via copper and check you get dhcp
Then check that the SFP port on the unifi is on the same profile as the copper uplink
Then check the HP switch, it’s a 18 so I think that means no CLI…

Half way through that I remembered that I have a 1810 connected to the network here!
Assuming the 1820 is similar to the 1810 the vlan config is a bit of a pain in the bum but you probably need to make sure that the SFP port is T on all and not U on anything. Hitting apply between the changes for each vlan.

My 1810 is talking happily to unifi gear but only over copper. I could go find some SFP modules and test if you are still really stuck.

I have a great deal of experience with vlans, no offense taken. Never had to deal with 1800 series. Always 2900s, Cisco, or Unifi.

I have a strange feeling it has something to do with the way they set up the default lan. The default lan (vlan 1) on the HP switches is there, but is excluded on all of the SPF ports on the HPs. All of the switches and WAPs have IP’s from vlan 10, which is also where the DHCP server is located. I had to set the default management lan to vlan10 when setting the unifi gear to static ips. I’m debating on ripping out the HP gear and just replacing it with Unifi 48 ports. The 1800s are from 2015, so they are do. I just hate not being able to figure these out.

Slightly delayed response here sorry.

I was taught, many, many years ago not to use vlan 1 for anything because some kit will just block it regardless of what it’s told. The person who told me this had a load of problems with Netgear kit and that ended up being his solution. Leave 1 only on the switch, any communication out is on > 1.

I reality, I suspect it’s an issue with 1 being tagged and that if you left it untagged it would be fine but I’m not totally sure.

Switch the management vlan on the 1800’s over to 10 and I suspect you will be golden.

(then once it’s working and you have satisfied that “why doesn’t it work” question go ahead and replace them!)

@garethw ,
Vlan 1 was excluded on all ports. It was a really strange situation. I think there was an issue with unifi’s default lan and the main data network being on a vlan. I don’t know if creating another vlan and making it the default lan for unifi would do the trick.

I went and replaced all of the gear with Unifi over the weekend. Still annoying issues, but everything is talking correctly.

The sad part is I can’t just plug in a unifi device and have it show up in the controller. I have to configure the device to change the mgmt_vlan and force it to a static ip. Also, the unif map doesn’t work, which would be helpful in this instance. It’s all good for now. Thanks for your help.

No problem glad you have it working. sometimes rip it out and start again is the best plan.

I run all my gear with the management vlan on something other than 1. My normal process (depending on site) is to;
configure and label everything centrally then move it to it’s final location
put it in it’s final location, on the upstream switch untag on the management vlan, adopt, update, change the management vlan to the correct one, update the port on the upstream switch to Tag management (or all, or whatever).

it’s a little bit of extra work but leads to a better setup long term