Connect Linux to L2TP/IPSec VPN

I work remotely for a company that recently changed their firewall to a Miraki and the only VPN option is L2TP/IPSec. I’ve tried following various blog posts/ videos of people connecting Ubuntu to L2TP/IPSec VPNs but none have worked. On the Miraki support page it says at the bottom that in order for Linux to connect it needs to use RADIUS or Active Directory.
I have installed network-manager-l2tp-gnome and can setup a VPN connection, but it cannot connect. I don’t see any options to use other authentication like RADIUS or AD.
Has anyone here ever successfully connected to a Miraki or other L2TP/IPSec VPN from Linux?
I have been able to connect from Windows 7 and an iPhone
a relatively recently uploaded video I looked at was How to Configure L2TP on Linux

You should be able to get Free RADIUS from the Ubuntu repositories. Try using pf-Sense to set up the VPN connection.

In addition to the information in that YouTube video, in the IPsec settings for the VPN connection, use “3des-sha1-modp1024-modp1024” for Phase 1 Algorithms, and “3des-sha1-modp1024” for Phase 2 Algorithms.


See here.