Cloud Key Gen 2 setup issues

Hey all, I am trying to add a Cloud Key Gen 2 plus to my mostly Ubiquiti network. I say mostly because I am using a Sonicwall device instead of a Ubiquiti security gateway. Everything else (2 48 port Pro switches and a handful of APs are Uni and already setup). The cloud key will be replacing the Unifi Network application I have installed on a desktop PC currently controlling the network.

I installed the Cloud Key, it booted and I began to set it up using the UniFi Network app on my phone via bluetooth.

It seems like the setup finished but I can’t see the Cloud Key listed in the app…Odd. So I looked at the IP on the Cloud Key display and hit that with the browser. At this point, I get a login screen with the name of my cloud key I choose during setup displayed. However, NO account will work. Not my Uni account, not root, not ubnt, etc.

So, I thought perhaps using my phone to set it up was a bad move. I reset the device to factory default and once it booted back up, went to the displayed IP using my laptop browser and tried to set it up there. I get the below page. Note the URL…

It seems I SHOULD get something like this instead but I never see this page:

I continue through a couple of setup screens asking for the name of my device, if its personal or business use, etc.

I finally get to a login screen but again, no credentials work here either.

So I am at a loss…I can login without any issues to my current UniFi network controller and the without issue.
I should note, I have tried to use the account username and email for this login. Neither work.

I sent a note to Ubiquiti support and honestly, they haven’t been able to provide a ton of help.

So aside from punting this thing in the trash :slight_smile: do you folks have any suggestions on what the issue could be?

Not a problem I have encountered but my guess would be something is being blocked by the Sonicwall that would allow the cloudkey to reach out.

Thanks for the reply! I did encounter an issue early on due to outbound firewall rules. I ran packet capture to see what was being requested and opened as needed. That got me to the point that I am at now. Sorry for not mentioning that.

Additionally, thinking I missed something, I opened the firewall wide open just as a test and that did not resolve the issue I outlined in my initial post.

Thanks again!