Clone Disk (convert it to a VM) with a Windows 10 Bitlocker volume


I have a laptop with a 256GB M.2 with a Windows 10 volume that is encrypted with Bitlocker.

I have mounted that M.2 in another Windows Desktop and tried to get a copy from it with multiple different software.

First, I unlock Bitlocker drive with it’s key (28 digit if I remember ok). Then I have tried to create an VHDX with all it’s volumes, not only the Microsoft Windows, there are thre more volumes:

128MB - fs: Other
500MB - fs: FAT32
826 MB - fs: NTFS

and the Windows 10 volume:

237,05 GB - fs: NTFS

I suppose that the three volumes are a recovery and maybe one for partitions table or so. I don’t have too much idea about this, sorry.

Well, I tried Disk2vhd, created an VHDX, but I think that Virtualbox doesn’t support it and when I tried to add to a VMWare Workstation as an existing disk, VMWare did not recognized it.

I have tried to create an VHD too with Disk2vhd, but I think that it cannot create that VHD with all 3 volumes inside, so it must be an VHDX.

I have created an vmdk image via Starwind V2V Converter with options:

P2V -> Physical Disk -> Selected all available volumes from the M.2 disk -> Local file -> VMDK -> VMWare Workstation growable image

It also does not boot on VMWare or Virtualbox.

I have tried to convert that vmdk image to vdi format algo via:

VBoxManage clonehd --format VDI “e:\My Backups\DESKTOP-JIF4TO5.vmdk” Virtual.vdi

“Boot failed. EFI DVD/CDROM” error.

I am pretty sure that I am missing something and that someone is gonna tell me that it’s is too much easy that what I were trying before.

I forgot to mention that I have tried Hyper V, can’t remember but I think that it was with a VHDX, with no luck. I want to avoid Hyper V it if possible anyway.

I think that disks that boots from a Bitlocker encrypted volume are not supported by VMWare, but I suppose that, for example, VHDX image was unencrypted one, I could mount it and access files. I don’t understand why it does not work with VMWare or Virtualbox.

Please, help.

1 Like

I would just try removing the bitlocker encryption since it’s hardware tied. Then if you wish, you can re-enable it in a VM with a virtual TPM device added.