Chelsio nic goes down after a few minutes

Hi,

I got two used Chelsio 110-1160-50 T520-CR nics off ebay.

One of them seems to work fine. The other works as expected, but after about 5 - 10 minutes, suddenly goes down. That is to say, in Freenas it reports as “down” in the interfaces menu, and in Windows it shows “Network cable unplugged” in the control panel. Tried swapping the nics, it’s always the same one that goes down regardless of which box its in. Doesn’t seem to matter which port I use on the card. Takes a hard reboot, sometimes several, to get it to come back up.

I tried installing the newest Unified Wire software from Chelsio.

Is there anything I can try or is it a bad nic?

Thanks!

EDIT:

It seems like the only way I can get it to come back is physically power down both the boxes, not just the one with the dodgy card (they’re connected peer to peer).

First google to see if others have had that issue, if not then might be a bad NIC.

that was the first thing I did, couldn’t find anything :confused:

Are you sure the nic is genuine? If so, then it seems the nic is bad.

Are there any options in BIO’s in regards to the NICs that can be fiddled with?