Can't connect to TrueNas from different subnet through Pfsense

So I just setup pfsense this weekend and the one issue I have remaining is that I cannot connect to my Truenas system from other systems. I have two Nics in the pfsense box and each port is a separate network.

MacMini is 192.168.10.101
Truenas is 192.168.30.101

On truenas I have a static IP matching 192.168.30.101. When I go to https: // 192.168.30.101 on my macmini, it times out.

So I am trying to determine if the problem is pfsense or truenas. One thing I remember is that on truenas I may have set a “static route” thinking that would fix my problem. And now I dont know how to reset the truenas networking without removing all my settings and other things.

My pfsense rules:

Check that the TrueNAS has the proper default gateway in the TrueNAS network config.

It doesnt give me the option to change the gateway.

Can TrueNAS ping 1.1.1.1?

No it doesnt look like it.

Then your TrueNAS probably needs the default gateway set.

How do I do that? I dont see the option in the set network config options.

In TrueNAS It’s under “Network Global Configuration”

I am not in web gui, im in console. Cant get to webgui.

I never tried it from the command line leaving two options:

  1. You will have to do some googleing or post in the TrueNAS forums (unless someone else here answers)
  2. Plug a computer into the same subnet and use the web UI

Put a machine on the same vlan as the truenas, and you will able to access truenas via gui.

Is there a way to tell what the gateway is via console? I need to know to set pfsense to it.

Surely you should known what IP address you added to the gateway setting on Truenas.

If connected to the Truenas console, option 1 allows you to change IP address.

image

You need to add the gateway on pfsense, set it to the Truenas Lan IP settings taken from PFSense.

Weird. When I plug my macmini into the truenas port (patch panel) it assigns a public ip and not lan ip. Also there is no “router” listed in the macos network settings.

You have some networking issues, check the settings on your pfsense device, as you should only get the IP from the IP address range / dhcp assigned to that pfsense port.

Take out the switches, patch panel and connect machines directly to the pfsense port.

Question that will help me solve this:

If I have a 4 port intel NIC, but there is one intel NIC on the motherboard,
and I have igb0-igb4 which one is the motherboard nic?

GOT IT!
It was IGB1. lol.

I had the assignments wrong.