Can TrueNAS restore a FreeNAS config?

I am updating my FreeNAS 11.3U5 to TrueNAS 12. Can I upload config taken from FreeNAS 11.3 (with secret) to a fresh TrueNAS core install? It must successfully attach the ZFS disks and mount the pools and datasets. Searched for clues in the TrueNAS docs, but got nothing.

Having read of problems with USB boot partitions (horrendous timeouts during installation to a USB device - Wendle, Level 1 tech) I will use a new SATA boot device with a fresh TrueNAS core install. Then I will load the FreeNAS config, and hope it takes.

If TrueNAS won’t load the FreeNAS config I could load a matching FreeNAS version, load the config, and then do an in place upgrade.

As I will have the USB boot devices unchanged and can always go back to FreeNAS if TrueNAS can’t upload the FreeNAS config or the upgrade fails. I read that the a upgrade bug in ZFS is fixed in FreeNAS 11.3U4, so have noted it is wise to upgrade FreeNAS to 11.3-U4 or 11.3-U5 before attempting an upgrade to TrueNAS 12.

Any experiences, helpful ideas and comments welcome.

You should be fine as long as you exported the config with the keys if your pools are encrypted or have the keys available separately. If the pools aren’t encrypted you won’t need to worry about that part.

I might put in the new SSD for system, and then load 11.3 and restore your config. Then change the upgrade path to 12 and let it do an automated upgrade. Takes more time, but it should get the job done. Here is a benefit of this method, if the upgrade goes wrong, you could boot back into 11.3. If you do a clean install of 12, there is no fall back. Might be worth something, might not.

I’ve auto-upgrade 2 of my servers from 11.3 to 12 without issue so far, and another few that still need to go from 11.1 up to 12 that will need to wait until Summer.

Thanks for the suggestions!

In the end I was cautious and installed 12.3U5 onto the Sata drive first, got that to boot (BIOS mode as UEFI would not boot - mobo too old maybe) then restored the config. When that worked ok I upgraded it to TrueNAS 12U1. Success.

While at it, replaced a 4 core AMD FX with a 6 core AMD FX processor, a better cooler and put in an HP LSI SAS perc controller instead of using the mobo SATA ports for more speeeeed. Usually, something goes wrong, but this is one of those “worked first time” (and framed it) times. Don’t see that often eh?


1 Like