Can I get a hand with this HAproxy reverse proxy not working?

I cannot for the life of me figure out why this isn’t working. I have a service at through http. It’s a media server called Jellyfin and I can access it with the aforementioned IP fine, so it’s up and running. I want to be able to access it from my office TV as well though, so I employed ACME and HAproxy. The ACME cert issued fine, so I know that part is good. I run my FQDN through Cloudflare and have DDNS setup in pfSense, all working fine. If I open a command prompt and issue: nslookup I’m returned my correct WAN IP so it would seem that is working as planned too.

I set up a simple backend for the service and a front end as well. When I try to access from my phone(not connected to LAN) I just get a “This site can’t be reached. unexpectedly closed the connection”.

Where can I look for more information? Status > Package Logs > haproxy is for some reason, empty.

screenshots of everything

I tried and got this screen:

Alright, well, first… whoops for displaying the actual domain lol… luckily it’s just here and you all are awesome. Weird, what do I do with that error?

Got it working. I had the wrong cert chosen - thanks!!!