Bufferbloat limiters nog working

Few months ago I bought a new system for my pfsense:

I configured a 2 port LAG port and set my 7 vlans as trunk over this lagg0 interface.
This works beautifully for local traffic between vlans.

The problem i have is with the wan. I have high ping times, video en audio streams are constantly disturbed.

I contacted my ISP they tested and measured my cable modem for 7 days and concluded there is nothing wrong with the modem and/or Internet connection.

So the problems should probably be within my own network.

While searching I found and used Tom’s video below and set that up.

I did what Tom is explaining in this video.
I have btw ipv4 and ipv6
I can’t select both gateways in de floating rule so i made 2 floating rules and use the same limiters for both IPv4 and IPv6.

Wen i test it is not working. Ping times are still crazy high.
I looked over the settings several times and don’t see any difference between Tom’s settings and mine besides 2 floating rules for IPv4 and IPv6

I don’t understand why it is not working.

Have you forced the wan internet link to be 1GB

This might help

No it is still the default setting (auto).
Should I set it to 1Gbit or is auto oke?

I used this video of Tom but no luck.
Also there was an error and i seems i should switch from codel to taildrop see here.
So i changed to taildrop but still no change ping times still crazy high.