Arista 7050s vlans, third party tranceivers and management configuration


I’m trying to setup my Atista 7050s52 but failing somewhere.

I gave an ip to the managemrnt console and can ssh into it.

I’d like to connect it to say port 48 to get it reachable from other port(s).
to setup vlan interface(s) with ip to make the switch reachable from those ports.

Now, I’m using a couple of sfp to rj45 tranceivers (1000baseT) in the switch’s sfp+ ports. The ports’ leds are yellow when I put the tranceiver in.

All that said, it seems I can’t set a port with the transceiver to a vlan, the commads seem to work but the port remains in “no vlan” state.

Is the transceiver the problem? Is something else I’m probably missing?

Thank you.

The SFP+ port might need to have the speed manually forced to 1gbps to match the module. I had to contact support for one of my Mikrotik switches because I was having modules that didn’t know how to tell the switch what speed they could use. Use case was the same, 10gbps SFP+ port with 1gbps copper module installed.

After that, I have no experience with your switch, but maybe the above helps. Also after inserting the modules, power cycle the switch. All my old Cisco gear requires a power cycle before they see the modules (2960s and 3560 switches).

1 Like

Ok, just needed to put an empty enable3px file in /mnt/flash, and power cycle the switch to make the transceivers work (this trick seems to only work on old Arista switches like mine).

You pointed me to the right direction, thank you very much.

Now I need to Everything solved:

  • clear a “Cpu” port in my VLAN (what’s that?) Solved: whenever I create a vlan interface, the switch shows a “cpu” port among the vlan ports.
  • see if I can connect the eth management port to the eth port on VLAN 100. I have actually two ports on vlan 100 with the transceivers, I can see my LAN if I connect a port to the LAN and the other to the PC, the PC receives its IP and gets to the internet (actually writing here through the switch’s transceivers). The management port, though, doesn’t seem to get connected to the transceiver. If I change the LAN cable with the management port cable, and put the PC on the same network, it doesn’t ping the switch. The management port is flawlessly connected to VLAN 100, probably just needed some time to get in the network.